Bug 117805 - rc.sysinit does not start RAID devices if they are not explicitly listed in fstab
Summary: rc.sysinit does not start RAID devices if they are not explicitly listed in f...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-08 19:30 UTC by Rick Wagner
Modified: 2014-03-17 02:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-28 22:28:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rick Wagner 2004-03-08 19:30:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040130

Description of problem:
Have a system with RAID-0, RAID-1 and RAID-5 drives (using kernel MD
for software RAID).  The RAID-1 drives (/dev/md0 on my system) start
at boot because it is explicitly mentioned in fstab.  

The other md? devices have LVM logical volumes built on top of them. 
Thus the RAID devices (/dev/md[12]) are not explicitly listed in
fstab; the logical volumes on top of them are in fstab.

Thus the lines (460-464) in rc.sysinit:
>                       INFSTAB=`LC_ALL=C grep -c "^$i" /etc/fstab`
>                       if [ $INFSTAB -eq 0 ] ; then
>                           RESULT=0
>                           RAIDDEV="$RAIDDEV(skipped)"
>                       fi

cause the unmentioned (but needed) RAID devices to not be started. 
Commenting those lines out brings up my storage.



Version-Release number of selected component (if applicable):
initscripts-7.42-1

How reproducible:
Always

Steps to Reproduce:
1. Create RAID drive.
2. Make a volume group and logical volume on to of it.
3. Set the logical voulume to automount in fstab.
4. Restart.

Actual Results:  Logical volume is not mounted.  RAID unit beneath was
not started.

Expected Results:  The RAID unit should have been started, and the
logcal volume mounted.

Additional info:

I first saw this in RH9, when I first started using LVM.

Comment 1 Frode Tennebø 2004-10-31 19:57:38 UTC
Can confirm this behaviour for RH9 at least. I added the following 
right below the NOAUTO-if an it works for me:

                        LVMRAID=`LC_ALL=C grep -c "$i" /etc/lvmconf/
*.conf`
                        if [ $LVMRAID -gt 0 ]; then
                            RESULT=1
                            RAIDDEV=`basename $i`
                            echo -n "LVM is using MD: "
                        fi


Comment 2 Bill Nottingham 2005-04-28 22:28:21 UTC
This is fixed in the current devel initscripts for FC4.


Note You need to log in before you can comment on or make changes to this bug.