Bug 117806 - evolution crashes trying to print
evolution crashes trying to print
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-08 14:41 EST by Brian Millett
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 16:30:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2004-03-08 14:41:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040302 Firefox/0.8.0+

Description of problem:
Evolution 1.4.5-7 will core when trying to print.  I have a system
that is updated on a latest from development.  I rolled back evolution
to the 1.4.5 rev and solved all dependencies.  Here is the trace of
the core:

#0  0x40000a52 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x40049aab in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x033f40d4 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  0x0809c7e9 in evolution_storage_set_view_factory_new_view ()
#4  <signal handler called>
#5  0x005ca9c0 in gtk_combo_box_get_model () from
/usr/lib/libgtk-x11-2.0.so.0
#6  0x00a16423 in gnome_print_unit_selector_get_unit ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#7  0x00a1621b in gnome_print_unit_selector_new ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#8  0x00a1802d in gnome_paper_selector_get_type ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#9  0x00a1942f in gnome_paper_selector_new_with_flags ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#10 0x00a19475 in gnome_paper_selector_new ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#11 0x00a10e6b in gnome_print_dialog_construct ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#12 0x00a10b65 in gnome_print_dialog_new ()
   from /usr/lib/libgnomeprintui-2-2.so.0
#13 0x4038be18 in vfolder_edit_vfolders ()
   from /usr/lib/evolution/1.4/components/libevolution-mail.so
#14 0x002f2cf1 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#15 0x002dd310 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#16 0x002f2795 in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#17 0x002f1757 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#18 0x002f1a54 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#19 0x0076a7a7 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#20 0x0066b382 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#21 0x0066a49f in _gtk_menu_shell_activate ()
   from /usr/lib/libgtk-x11-2.0.so.0
#22 0x00661b77 in gtk_menu_reorder_child () from
/usr/lib/libgtk-x11-2.0.so.0
#23 0x006588d5 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#24 0x002dd6a7 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#25 0x002dd310 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#26 0x002f21d5 in g_signal_emit_by_name () from
/usr/lib/libgobject-2.0.so.0
#27 0x002f152e in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#28 0x002f1a54 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#29 0x0076a5b2 in gtk_widget_send_expose () from
/usr/lib/libgtk-x11-2.0.so.0
#30 0x006568f9 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x00655498 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x0085ea05 in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#33 0x00278c75 in g_get_current_time () from /usr/lib/libglib-2.0.so.0
#34 0x00279d28 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#35 0x0027a060 in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#36 0x0027a7c1 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#37 0x03e030a8 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#38 0x0809cbe4 in main ()


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.update system with latest from development
2.launch evolution-1.4.5-7
3.click on the printer icon

    

Actual Results:  evolution stops with a fatal crash

Expected Results:  that it prints

Additional info:
Comment 1 Daniel Malmgren 2004-03-12 10:10:42 EST
I get the same in 1.4.5-8

I might note that I also get an immediate crash (instead of a nice
requester) when chosing "Print..." from the menu.
Comment 2 Daniel Malmgren 2004-03-12 10:14:11 EST
Forgot to mention two things:
1. Printing has worked in this exact evo version for me earlier
2. There is no problem printing from other programs
Comment 3 Daniel Malmgren 2004-03-12 10:20:49 EST
Guess this is the same as
http://bugzilla.ximian.com/show_bug.cgi?id=54806 and if it is, an
updated gnome-print should do the trick. I've got
libgnomeprint22-2.5.3-1 installed right now.

Oh, and sorry for the mailbombing ;-)
Comment 4 Daniel Malmgren 2004-03-16 15:36:48 EST
Updating to latest libgnomeprint22 fixes this one for me.
Comment 5 Brian Millett 2004-03-16 16:30:38 EST
Also, the 1.4.6 release allows printing.

Note You need to log in before you can comment on or make changes to this bug.