Bug 1178194 - [RFE] Automate content host configuration into a script or streamline somehow
Summary: [RFE] Automate content host configuration into a script or streamline somehow
Keywords:
Status: CLOSED DUPLICATE of bug 1154373
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Inter Satellite Sync
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-02 19:28 UTC by Matt Reid
Modified: 2017-02-23 20:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-05 15:23:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Reid 2015-01-02 19:28:51 UTC
Description of problem:
As detailed in https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Populating_Red_Hat_Satellite_with_Content-Disconnected_Satellite.html
there are a number of manual steps required to get a content host properly configured, requiring editing several different config files, generating keys and transcribing those keys to other places, fiddling with repositories and services, and installing packages. 

If all of these steps are required, it would be nice if there was some way to reduce the amount of manual configuration and copy-pasting values between config files. All of these steps seem fairly trivial, could we wrap them into a script that steps the user through, in case someone isn't closely following the documentation when trying to set things up? It would reduce the chance of errors creeping in.

Comment 1 RHEL Program Management 2015-01-02 19:54:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Bryan Kearney 2015-01-05 15:23:50 UTC

*** This bug has been marked as a duplicate of bug 1154373 ***


Note You need to log in before you can comment on or make changes to this bug.