Bug 1178204 - Not sure what Search on Content > Red Hat Subscriptions actually searches
Summary: Not sure what Search on Content > Red Hat Subscriptions actually searches
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Christine Fouant
QA Contact: Corey Welton
URL:
Whiteboard: Verified in Upstream
Depends On:
Blocks: 1317008
TreeView+ depends on / blocked
 
Reported: 2015-01-02 21:08 UTC by Matt Reid
Modified: 2019-11-14 06:35 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:46:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Full table (89.23 KB, image/png)
2015-01-02 21:08 UTC, Matt Reid
no flags Details
0 results after searching for "red" (30.45 KB, image/png)
2015-01-02 21:08 UTC, Matt Reid
no flags Details
0 results after searching for "linux" (30.29 KB, image/png)
2015-01-02 21:09 UTC, Matt Reid
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2137221 None None None 2016-01-24 21:35:50 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Matt Reid 2015-01-02 21:08:04 UTC
Created attachment 975381 [details]
Full table

Description of problem:
I'm not sure how to use the Search on the Content > Red Hat Subscriptions page. Searching for "Red" or "red" or "linux" returns 0 results. After removing the Search, the first three subscriptions listed in the table contain "Red Hat Enterprise Linux..." in the subscription name. We've called it Filter elsewhere in the UI, but here it's Search.

What does Search look through? Is it a bug or functioning as intended for it to not find subscriptions by name?

Version-Release number of selected component (if applicable):
6.0.4

Comment 1 Matt Reid 2015-01-02 21:08:38 UTC
Created attachment 975382 [details]
0 results after searching for "red"

Comment 2 Matt Reid 2015-01-02 21:09:18 UTC
Created attachment 975383 [details]
0 results after searching for "linux"

Comment 3 RHEL Program Management 2015-01-02 21:24:03 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Christine Fouant 2015-10-21 19:09:54 UTC
Fixed by https://github.com/Katello/katello/pull/5446

Comment 7 Tazim Kolhar 2015-11-04 11:44:12 UTC
*** This bug is verified in upstream.  This fix should eventually land in future downstream builds ***
Version Tested:
# rpm -qa | grep foreman
foreman-proxy-1.11.0-0.develop.201510201341git00875b3.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
foreman-debug-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-compute-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-release-scl-1-1.el7.x86_64
foreman-gce-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-vmware-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
hp-z600-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-ovirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-release-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-libvirt-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
foreman-postgresql-1.11.0-0.develop.201510271601git4e08a71.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201510201150gitab068d9.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch

steps:
Search on the Content > Red Hat Subscriptions page

Comment 8 Stuart Auchterlonie 2015-11-04 14:52:09 UTC
Does this fix searching for subscriptions by contract number?

Comment 12 errata-xmlrpc 2016-07-27 08:46:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.