Bug 117823 - gpilotd crashes when ECalendar or EToDo conduits start
gpilotd crashes when ECalendar or EToDo conduits start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-pilot (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-08 18:21 EST by Ben Steeves
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 19:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Steeves 2004-03-08 18:21:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040217 Epiphany/1.1.10

Description of problem:
Gpilotd consistently crashes when reaching the ECalendar conduit.  If
I disable ECalendar, it crashes when reaching EToDo.  I'm syching via
serial to a Tungsten T3.  I've included a log of debug messages
printed by running gpilotd at a shell prompt.

If I disable the ECalendar & EToDo conduits, the sync completes normally.

As it is, it is impossible to get data from Evolution to the handheld.

Version-Release number of selected component (if applicable):
gnome-pilot-2.0.10-6

How reproducible:
Always

Steps to Reproduce:
1. start gpilotd
2. hotsync

    

Actual Results:  gpilotd segfaults

Expected Results:  conduit should synchronize correctly

Additional info:

[bcs@ripley bcs]$ /usr/libexec/gpilotd
gpilotd-Message: gnome-pilot 2.0.10 starting...
gpilotd-Message: compiled for pilot-link version 0.11.8
gpilotd-Message: compiled with [VFS] [USB] [IrDA] [Network]
gpilotd-Message: Activating CORBA server
gpilotd-Message: bonobo_activation_active_server_register = 0
gpilotd-Message: Watching Cradle (/dev/pilot)
gpilotd-Message: Woke on Cradle
gpilotd-Message: setting PILOTRATE=115200
gpilotd-Message: Cradle Cradle has 0 events
gpilotd-Message: Instantiating 5 conduits...
eaddrconduit-Message: in address's conduit_get_gpilot_conduit
 
ecalconduit-Message: in calendar's conduit_get_gpilot_conduit
 
etodoconduit-Message: in todo's conduit_get_gpilot_conduit
 
gpilotd-Message: Instantiated 1 backup conduits, 1 file conduits, 3
other conduits
gpilotd-Message: HotSync button pressed, synchronizing pilot
gpilotd-Message: Pilot ID is 4782, name is T3, owner is Ben Steeves
gpilotd-Message: Pilot has 0 entries in restore queue
gpilotd-Message: Pilot has 0 entries in conduit queue
gpilotd-Message: Pilot has 0 entries in file install queue
[backup conduit messages removed]
eaddrconduit-Message:
---------------------------------------------------------
 
eaddrconduit-Message: pre_sync: Addressbook Conduit v.0.1.2
 
(gpilotd:5895): libebook-WARNING **: conversion to EBookQuery failed
 
(gpilotd:5895): libebook-CRITICAL **: file e-book.c: line 1095
(e_book_get_contacts): assertion `query' failed
 
(gpilotd:5895): GLib-GObject-CRITICAL **: file gobject.c: line 1579
(g_object_unref): assertion `G_IS_OBJECT (object)' failed
 
(gpilotd:5895): gpilotd-WARNING **: Synchronization failed!
[more backup conduit messages removed]
ecalconduit-Message:
---------------------------------------------------------
 
ecalconduit-Message: pre_sync: Calendar Conduit v.0.1.6
 
(gnome_segv:5945): Gtk-WARNING **: Ignoring the separator setting
[bcs@ripley bcs]$
Comment 1 Jeremy Katz 2004-03-08 18:22:04 EST
evolution 1.4.x or 1.5.x?
Comment 2 Ben Steeves 2004-03-08 18:23:53 EST
evolution-1.5.3-1
evolution-data-server-0.0.6-1
Comment 3 Jeremy Katz 2004-03-08 18:40:43 EST
Can you downgrade to 1.4.5 (which is currently in the development
tree) and see if it still happens there?  We're having to backrev to
1.4.x due to the evolution 2.0 schedule slipping
Comment 4 Ben Steeves 2004-03-08 19:37:32 EST
After downgrading to evolution-1.4.5-7 things are working again.  

I'm not sure how you'd want to file this bug, as it will probably come
up again under Evo 1.5.

Note You need to log in before you can comment on or make changes to this bug.