Bug 1178233 - add el6 support
Summary: add el6 support
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-execnet
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1180031 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-02 23:40 UTC by Ken Dreyer
Modified: 2015-02-08 19:23 UTC (History)
3 users (show)

Fixed In Version: python-execnet-1.2.0-4.el6.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-08 19:23:08 UTC
Type: Bug


Attachments (Terms of Use)
add el6 support to python-execnet (1.67 KB, application/mbox)
2015-01-02 23:40 UTC, Ken Dreyer
no flags Details

Description Ken Dreyer 2015-01-02 23:40:34 UTC
Created attachment 975491 [details]
add el6 support to python-execnet

Here's a patch to support building python-execnet 1.2.0 on EL6.

The changes are conditionalized out so they won't affect other dists. If it's acceptable to you, I'd prefer to get this into Rawhide. By keeping the git branches identical we can continue to do fast-forward merges.

Comment 1 Thomas Moschny 2015-01-07 17:19:08 UTC
(In reply to Ken Dreyer from comment #0)
> Here's a patch to support building python-execnet 1.2.0 on EL6.

The patch skips the tests on EL6 - that is something I don't like. Any chance to get the tests fixed, or at least isolate a smaller set of failing tests?

I've always put a lot of effort into getting the testsuite running, would be too bad to simply deactivate it for EL6 now.

> The changes are conditionalized out so they won't affect other dists. If
> it's acceptable to you, I'd prefer to get this into Rawhide. By keeping the
> git branches identical we can continue to do fast-forward merges.

That's perfectly fine.

Comment 2 Ken Dreyer 2015-01-07 17:46:53 UTC
(In reply to Thomas Moschny from comment #1)
> The patch skips the tests on EL6 - that is something I don't like. Any
> chance to get the tests fixed, or at least isolate a smaller set of failing
> tests?
> 
> I've always put a lot of effort into getting the testsuite running, would be
> too bad to simply deactivate it for EL6 now.

I agree, and I spent at least two hours trying to narrow down what exactly is causing this. When I ran the test suite via "mock shell", it ran fine. I tried stripping out various test files, etc. During my testing I found that the tests appeared to hang in four separate files. These files worked fine when I ran them individually.

It was at that point that I determined that I didn't know enough about Python 2.6's internal workings to understand what exactly is hanging.

If you're able to get it to work, that would be fantastic!

Comment 3 Thomas Moschny 2015-01-08 18:03:10 UTC
*** Bug 1180031 has been marked as a duplicate of this bug. ***

Comment 4 Thomas Moschny 2015-01-13 15:34:30 UTC
Current state:

Tried to build with conditionalized python-gevent for various branches:

epel7: http://koji.fedoraproject.org/koji/taskinfo?taskID=8589451
el6:   http://koji.fedoraproject.org/koji/taskinfo?taskID=8574979
f20:   http://koji.fedoraproject.org/koji/taskinfo?taskID=8574941

these worked. Interestingly, now these fail:

devel: http://koji.fedoraproject.org/koji/taskinfo?taskID=8574791
f21:   http://koji.fedoraproject.org/koji/taskinfo?taskID=8574803

Need to find out why.

Comment 5 Ken Dreyer 2015-01-16 00:07:45 UTC
It looks like there are some deeper problems with the test suite in mock? Maybe we should run it, but not make the RPM build fail when the test suite fails?

Comment 6 Thomas Moschny 2015-01-16 18:42:13 UTC
(In reply to Ken Dreyer from comment #5)
> It looks like there are some deeper problems with the test suite in mock?
> Maybe we should run it, but not make the RPM build fail when the test suite
> fails?

It's not a mock thing. I got hands on a F21 machine, and the testsuite fails for a local rebuild, too. Investigating.

Comment 7 Fedora Update System 2015-01-19 15:22:43 UTC
python-execnet-1.2.0-4.el6.1 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-execnet-1.2.0-4.el6.1

Comment 8 Fedora Update System 2015-01-24 18:43:22 UTC
python-execnet-1.2.0-4.el6.1 has been pushed to the Fedora EPEL 6 testing repository.

Comment 9 Fedora Update System 2015-02-08 19:23:08 UTC
python-execnet-1.2.0-4.el6.1 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.