Bug 117827 - /etc/rc.d/rc fails always
/etc/rc.d/rc fails always
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-08 18:59 EST by Enrico Scholz
Modified: 2014-03-16 22:43 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-16 18:44:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-03-08 18:59:28 EST
Description of problem:

Last command in /etc/rc.d/rc is

| [ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --quit

Therefore, the return code signals everytime an error which is not
very nice and can cause malfunctions e.g. in vserver startup.

Since the 'rhgb-client --quit' command fails on non-started rhgb
server, I suggest to rewrite the statement above to

| [ ! -x /usr/bin/rhgb-client -o ! -S /initrd/rhgb-socket ] ||
/usr/bin/rhgb-client --quit


A more simple solution would be to append a 'true' to the script.
Since there is no other indication about success/failure in the
script, this would not change the oeverall behavior.



Version-Release number of selected component (if applicable):

initscripts-7.46-1.1
Comment 1 Enrico Scholz 2004-03-08 20:08:25 EST
rc.sysinit is doing this already with

| # Let rhgb know that we're leaving rc.sysinit
| if [ -x /usr/bin/rhgb-client ] && /usr/bin/rhgb-client --ping ; then
|     /usr/bin/rhgb-client --sysinit
| fi

so it should be no problem to apply this to 'rc' too (replace
--sysinit with --quit)
Comment 2 Bill Nottingham 2004-03-16 18:44:10 EST
Fixed, will be in 7.47-1.

Note You need to log in before you can comment on or make changes to this bug.