Bug 117834 - redhat-config-network crashes with a really large providerdb
Summary: redhat-config-network crashes with a really large providerdb
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 86560
TreeView+ depends on / blocked
 
Reported: 2004-03-09 02:00 UTC by Phillip Heller
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 1.3.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 13:38:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"question mark" (559 bytes, image/x-xpixmap)
2004-03-09 04:37 UTC, Phillip Heller
no flags Details
"blank" (439 bytes, image/x-xpixmap)
2004-03-09 04:38 UTC, Phillip Heller
no flags Details

Description Phillip Heller 2004-03-09 02:00:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
I've parsed my company's list of dialup numbers into the same format
as the /usr/share/redhat-config-network/providerdb that ships with
Fedora Core 1.

The file is rather large:

-rw-r--r--    1 root     root      1629531 Mar  8 18:37 providerdb

There is not a mistake in my parsing, my company really does have that
many dialups. 

I will attach the dump from redhat-config-network.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. replace stock /usr/share/redhat-config-network/providerdb with
another one containing far more entries.
2. attempte to choose a new ISP from the dialup configuration dialog.
    

Actual Results:  The application crashes.

Expected Results:  redhat-config-network should parse the file as it
does the smaller, stock version.

Additional info:

Comment 1 Phillip Heller 2004-03-09 02:10:34 UTC
So I'm just an idiot.  The actual problem here seems to be the lack of
an flag xpm for the specific country iso code as specified in the
[flag] directive.

So, the solution here is to either include an xpm for each flag, or
default to some xpm in the case a specific one does not exist.

Comment 2 Phillip Heller 2004-03-09 04:36:15 UTC
So, I've temporarily symlinked all the non-existant flag xpm's to one
of the oth
ers, and it is working.

However, it's worth noting that it takes a while to load and parse the
providerd
b file.  (On the order of 6 seconds)

Maybe it'd be worthwhile to compile the providerdb into a binary
format with an 
index; thus, only when expanding a country or city, would a portion of
the file 
need to be parsed.

Additionally, a dialog to search the provider list (based on area
code, etc) wou
ld be handy.  I will open another RFE for that, though.


------------

Back to the point at hand....

I have attached two xpm's to default to.  You're welcome to use one of
them as a
 default if you like.


Comment 3 Phillip Heller 2004-03-09 04:37:34 UTC
Created attachment 98391 [details]
"question mark"

An option for a default flag pixmap for redhat-config-network ISP selection.

Comment 4 Phillip Heller 2004-03-09 04:38:29 UTC
Created attachment 98392 [details]
"blank"

Another suggestion for a default flag pixmap for redhat-config-network ISP
selection.

Comment 5 Harald Hoyer 2004-04-21 13:15:28 UTC
ok, added to CVS


Note You need to log in before you can comment on or make changes to this bug.