Bug 117839 - RFE: redhat-config-network could use dialer profiles and the ISP selector could use a search function
RFE: redhat-config-network could use dialer profiles and the ISP selector cou...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2004-03-08 23:56 EST by Phillip Heller
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:21:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phillip Heller 2004-03-08 23:56:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
redhat-config-network could use dialer profiles.
------------------------------------------------

It would be convenient if you could create dialer profiles which
dictate the dialing policy for the current location.

For example, when I'm dialing from home, I might dial *70 to cancel
call waiting, and not prefix a call to the 303 areacode with 1 (as
it's a local call for me).

However, if I am in a hotel out of state, I might dial "9" for an
outside line, then dial "1" for long distance, since it would be a
long distance call to 303.

So, a dialer profile would need to record:

Location Name (Should allow punctuation and spaces, etc)
Current Country Code
Current Area Code
Disable call waiting (checkbox and textfield)
Local Prefix
Long Distance Prefix
Exchange Rules (force long distance prefix to be added to certain
numbers; i.e., 303-284 is local to me, as is the rest of 303, but if a
new exchange were created that wasn't, I could list it in the exchange
rules as a long distance number)

ISP Selector Search Function
-----------------------------------------------

It would be useful to have a search capability in the ISP selector.

Maybe a field where you could enter a regex filter?

In any case, it would be extremely useful if the phone number were
shown in the selection list, then it's easier to guess which number
might be a local vs. long distance call.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Feature not yet implemented


Additional info:

Note You need to log in before you can comment on or make changes to this bug.