Bug 117841 - service network start not starting eth0
service network start not starting eth0
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2004-03-09 01:03 EST by Michael Koziarski
Modified: 2014-03-16 22:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-28 21:43:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
ifcfg-eth0 (143 bytes, text/plain)
2004-03-10 13:24 EST, Michael Koziarski
no flags Details
The requested files (1.77 KB, application/octet-stream)
2004-03-11 00:23 EST, Michael Koziarski
no flags Details
network configuration file (273 bytes, text/plain)
2004-06-09 01:14 EDT, William
no flags Details

  None (edit)
Description Michael Koziarski 2004-03-09 01:03:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040217

Description of problem:
I recently updated to fedora core development from the fc2t1 release.
 Since that upgrade my eth0 connection no-longer starts on boot.

/etc/sysconfig/network-scripts/ifcfg-eth0 contains


and /etc/sysconfig/networking/profiles/default/ has a file called

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.  Boot the computer
2.  Try to use the network

Actual Results:  eth0 didn't start

Expected Results:  eth0 should have started.

Additional info:
Comment 1 Michael Koziarski 2004-03-09 01:04:21 EST
Let me know any files which should be attached.
Comment 2 Bill Nottingham 2004-03-09 14:09:05 EST
Do you have a firewire adapter?
Comment 3 Michael Koziarski 2004-03-09 14:15:09 EST
Yes.  Only used for my iPod though.  There's also another old&unused
network card in there.

Comment 4 Bill Nottingham 2004-03-09 14:19:13 EST
Does 'rmmod eth1394 ; ifup eth0' work?
Comment 5 Michael Koziarski 2004-03-09 15:04:34 EST
I've just arrived at work, I'll try that this evening (NZDT) when I
get home.
Comment 6 Michael Koziarski 2004-03-10 05:49:28 EST
ifup eth0 works irrespective of whether or not the eth1394 module is
loaded (it isn't on boot).

The only problem is that the ONBOOT=yes flag seems to be ignored.
Comment 7 Bill Nottingham 2004-03-10 11:35:48 EST
Can you attach the full ifcfg-eth0?
Comment 8 Michael Koziarski 2004-03-10 13:24:56 EST
Created attachment 98435 [details]

Sure,  Here's the file.  Any others you'd like?
Comment 9 Bill Nottingham 2004-03-10 13:25:54 EST
Are there any error messages?
Comment 10 Michael Koziarski 2004-03-10 13:49:38 EST
There are two errors on boot.   one is something about insmod failing
for a toshiba acpi module or something.

eth0 starts just fine according to the output.

Then when sshd is starting there's an ifup error about sit0 not existing.

Now, I just noticed that ifup eth0 didn't work this time, I needed to
use system-config-network.   I ran an lsmod before and after, here's
the diff:

 Module                  Size  Used by
+8139too                22016  0
+mii                     3712  1 8139too
+r8169                   9732  0
+crc32                   3968  2 8139too,r8169
+sg                     28064  0
+scsi_mod              101564  1 sg

Also,  when upgrading from fc1 to the test release, my onboard
ethernet 'became' eth0.  FC1 didn't even detect  it, but FC2t1 did and
replaced the 8139 card with it. 
Comment 11 Bill Nottingham 2004-03-10 14:31:37 EST
So, it *says* that it's bringing up eth0, but it's not actually up
after the boot process finishes?
Comment 12 Michael Koziarski 2004-03-10 15:48:49 EST
Yes,  that's correct.

I don't know if it's up halfway through or something, but the output
clearly says:

"Bringing up interface eth0     [  OK  ]"

ifup eth0 on the command line doesn't show any errors either, it just
doesn't do anything.
Comment 13 Michael Koziarski 2004-03-10 15:51:48 EST
that is.  It doesn't do anything after the boot.  Once I use
system-config-network to activate the interface ifup and ifdown work
as expected.

I assume it's some kind of module related thing?
Comment 14 Bill Nottingham 2004-03-10 16:05:45 EST
After booting, what does 'ifconfig eth0' say?
Comment 15 Michael Koziarski 2004-03-10 16:25:34 EST
I'll test that when I get home from work.  Any other files you think
may help?  modules.conf or whatever?
Comment 16 Bill Nottingham 2004-03-10 16:29:04 EST
modprobe.conf, ifcfg-*, and /etc/sysconfig/hwconf
Comment 17 Michael Koziarski 2004-03-11 00:23:36 EST
Created attachment 98450 [details]
The requested files

I'd never heard of /etc/modprobe.conf,	I can't help but noticing that there's
no alias eth0 8169
Comment 18 Michael Koziarski 2004-03-11 00:34:27 EST
Added alias eth0 r8169 and it starts on boot now.  However, for the
sake of consistency,  here is the ifconfig output you wanted.  Kind of
weird really.

[root@gandalf root]# ifconfig eth0
eth0: error fetching interface information: Device not found
[root@gandalf root]# ifconfig eth1
eth1: error fetching interface information: Device not found
[root@gandalf root]# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:05:1C:1A:1F:C2
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::205:1cff:fe1a:1fc2/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:418 (418.0 b)
          Interrupt:11 Base address:0xa000

Comment 19 Bill Nottingham 2004-03-11 01:10:19 EST
How did you upgrade?
Comment 20 Michael Koziarski 2004-03-11 01:14:02 EST
Downloaded the ISOs, burned them.  booted them and chose upgrade.

The card it's marked as eth1 in the modprobe.conf used to be eth0,
then upon installing FC2 it had finally detected my on board ethernet,
but marked it as eth0.

Maybe it was actually just an off by one error somewhere?
Comment 21 Bill Nottingham 2004-03-11 01:38:38 EST
Did kudzu ever pop up any warning dialogs about hardware changing for you?

(The problem is that the initial change to modprobe.conf probably
happened long enough ago that's its going to be tricky to track down
where it went wrong. :/ )
Comment 22 Michael Koziarski 2004-03-11 02:11:14 EST
I don't think it ever came up with warnings.   I haven't seen a kudzu
screen in a while.  Except when I had plugged in my ipod.

Truth be told, I always choose ignore there anyways.
Comment 23 Michael Koziarski 2004-03-11 15:37:33 EST
Given the quirky nature of this one how about this.

I have a test PC with two NICs,  I'll format it and install FC1, then
update to the test release.  Then yum update.  If I can reproduce this
I'll have all the information we need.  Otherwise, I'll mark this as
not a bug and assume that I screwed something up.
Comment 24 Michael Koziarski 2004-03-11 15:39:18 EST
Didn't mean to do that.  Javascript.
Comment 25 raxet 2004-04-29 09:00:46 EDT
I have had a similar experience here. Upgraded from FC2 T2 to T3 
yesterday using the iso's. Nothing errored out on upgrade. Then upon 
reboot, kernel messages shows the following:

Apr 28 20:51:33 maxer kernel: tg3: Unknown parameter `irq'
Apr 28 20:51:33 maxer kernel: ip_tables: (C) 2000-2002 Netfilter core 
team Apr 28 20:51:33 maxer kernel: ip_conntrack version 2.1 (8191 
buckets, 65528
max) - 296 bytes per conntrack
Apr 28 20:51:33 maxer kernel: tg3: Unknown parameter `irq'
Apr 28 20:51:33 maxer kernel: tg3: Unknown parameter `irq'

Apr 28 20:55:38 maxer kernel: tg3: Unknown parameter `irq'
Apr 28 20:55:38 maxer modprobe: FATAL: Error inserting tg3
(/lib/modules/2.6.5-1.339custom/kernel/drivers/net/tg3.ko): Unknown 
symbol in module, or unknown parameter (see dmesg)

Kudzu removes my NetXtreme BCM570X Gigabit Ethernet (tg3.ko), then re-
adds it. I reconfigure for my ADSL connection and then eth0 still is 

The entry in hwconf :
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: tg3
desc: "Broadcom Corporation|NetXtreme BCM5702X Gigabit Ethernet"
vendorId: 14e4
deviceId: 16a6
subVendorId: 1043
subDeviceId: 80a9
pciType: 1
pcidom:    0
pcibus:  2
pcidev:  5
pcifn:  0
Comment 26 raxet 2004-04-29 09:21:35 EDT
Resolved! Apparently the upgrade takes your modprobe.conf and puts an
alias in for eth0 and sets the IRQ for my tg3 to 9. Found a backup
that anaconda made back on March 7 and voila my network is just fine.

Comment 27 Ron 2004-05-19 15:53:23 EDT
Raxet, care to explain the resolution in a bit more detail?
Comment 28 ae 2004-05-23 16:58:36 EDT
I went ... -> FC2pre1 -> FC2, and after the last stage I was left
with these files in /etc:


where modprobe.conf stands out by its absence. Is my failure the same
as reporters?
Comment 29 Michael Koziarski 2004-05-23 17:21:44 EDT
No,  but it *is* the same as #121737, which is marked as fixed.
Comment 30 William 2004-06-07 17:24:23 EDT

I have a similar problem with Fedora Core 1. But in my case the line
"Bringing up interface eth0" doesn't show up during the boot process.
Everything was just fine before I ran a mass update using up2date.
Several packages have been downloaded and installed; I cannot remember
  all the names.

Some comments that might be usefull.

1. There's a line: alias eth0 8139too in /etc/modprobe.conf. 
Apparently the module is being loaded correctly.
2. There's no other file named "modprobe.***" besides ".conf" and
".conf.dist" in the /etc directory.
3. The command "ifup eth0" works perfectly after boot. Then I can
access the internet, mount remote filesystems, and so on.

Should I update to Fedora 2 now?
Is there any log file that I should check to figure out what went
wrong during last boot?
Comment 31 Bill Nottingham 2004-06-07 17:46:17 EDT
William: I doubt your problem is related at all.

If I had to guess, perhaps the network driver broke in the update you did?
Comment 32 William 2004-06-07 19:07:35 EDT
Ok, But if it is broken, how can I fix it? If it is really broken,
shouldn't it prevent the interface of loading after the boot process?
How can I make sure the driver is not loading since I see no error
messages. The line "Bringing up interface eth0" simply doesn't appear.

Sorry if this message is not directly related to this bug! 
Comment 33 Bill Nottingham 2004-06-08 00:38:45 EDT
What does your ifcfg-eth0 look like?
Comment 34 William 2004-06-09 01:14:44 EDT
Created attachment 100985 [details]
network configuration file
Comment 35 William 2004-06-10 03:48:08 EDT
I'm not experiencing this bug anymore. I'm runnig FC2 now. The 
upgrade corrected the problem, although some other bugs have shown 
up. :).
Comment 36 Paul W. Frields 2004-06-22 08:01:54 EDT
I happened to wander by this bug while searching for some other data
and noticed an alarming number of people doing unsupported upgrades,
and then being bitten by weird upgrade bugs. As a note to the many
people doing unsupported upgrades:

When you perform an upgrade, there are only a few routes that are
valid for testing. Upgrades from a final version to a test version are
OK. Upgrades from a test version to ANYTHING is NOT OK. If you want to
use a test version, the only valid ways to test its upgrade is to
upgrade from a FINAL version.

So if you want to test FC3testX, you have to either install it fresh,
or upgrade from FC2 FINAL. You can't upgrade from FC3test1 to FC3test2
and expect things to work right; that's not the way they're intended
to work. If you want to test FC3test2, and you already have FC3test1
installed, you will need to return to a FC2 installation by starting
fresh (probably a new install), and then upgrade straight to FC3test2.
This was discussed many times on fedora-test-list, but in case folks
missed it....

Obviously having a separate /home and backing up /etc from time to
time is highly recommended. Good luck all!
Comment 37 Michael Koziarski 2004-06-22 19:38:00 EDT
While it's certainly true that the upgrades aren't supported or
tested,   Stating that they are *NOT OK* is a dangerous position. The
anaconda upgrade process needs testing just like the rest of FC.  Test
n to n+1 upgrades work fine most of the time, and when they don't work
it's something that should be reported.

I know that such upgrades aren't supported, so when FC2 final was
released I reinstalled. 
Comment 38 Matthew Miller 2005-04-26 11:55:50 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 39 Bill Nottingham 2005-04-28 21:43:36 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response. Please reopen if this persists on a current release, such as Fedora
Core 3.

Note You need to log in before you can comment on or make changes to this bug.