Bug 117866 - Some binaries not stripped
Some binaries not stripped
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: distribution (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: dff
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 08:46 EST by Lance Davis
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:29:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
List of non stripped srpms/files (7.17 KB, text/plain)
2004-03-09 08:50 EST, Lance Davis
no flags Details

  None (edit)
Description Lance Davis 2004-03-09 08:46:23 EST
Description of problem:

Some binaries appear to not be stripped by brp-strip
list attached 

This may be because the information is not 'debug' information that
would be stripped by strip -g ???

This is in addition to 'shared object' objects not being stripped by
brp-strip, whereas they do appear to be by find-debuginfo.sh

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.  rebuild rpm
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lance Davis 2004-03-09 08:50:27 EST
Created attachment 98399 [details]
List of non stripped srpms/files
Comment 2 Jos Vos 2004-03-27 17:07:55 EST
Note that "full" stripping sometimes may cause (severe) problems.

If you strip dietlibc without -g (/usr/lib/dietlibc/lib-i386/start.o,
to be more precise) and build anaconda with that "fully-stripped"
dietlibc version, both anaconda's init and loader static binaries
WON'T WORK ANYMORE and your install boot will panic just after loading
initrd :-(.
Comment 3 RHEL Product and Program Management 2007-10-19 15:29:20 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.