Bug 117879 - add Tamil to FC2
add Tamil to FC2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 11:25 EST by Hariraam Aathreya
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 15:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hariraam Aathreya 2004-03-09 11:25:47 EST
Description of problem:

To check and add Tamil language in distribution.

Here are links to two GPLed Tamil Unicode fonts :
1. http://www.geocities.com/csd_one/fonts/vaigai.zip
   Font: VaigaiUni
   Author: Umar ( csd_one AT yahoo DOT com )

2. 
http://cvs.sourceforge.net/viewcvs.py/tamillinux/tamil-fonts/opentype/TSCu_Paranar.ttf
http://cvs.sourceforge.net/viewcvs.py/tamillinux/tamil-fonts/opentype/TSCu_paranarb.ttf
http://cvs.sourceforge.net/viewcvs.py/tamillinux/tamil-fonts/opentype/TSCu_paranari.ttf
   Font: TSCu_Paranar --- Normal, Bold, Italic versions
   Author: R. Kalaimani, Tharagai Software, Singapore.
   Opentype tables added by T. Vaseeharan ( t_vasee AT yahoo DOT com
Comment 1 Bill Nottingham 2004-03-09 13:58:14 EST
Assigning to font reviewer.
Comment 2 Owen Taylor 2004-03-09 15:30:37 EST
Would it be possible to answer the questions in
https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html
for the Tamil fonts that you think should be included?

Comment 3 Owen Taylor 2004-04-19 09:44:16 EDT
Note this is blocking on answers to these questions. Nothing
further will be done until I get a detailed proposal.
Comment 4 Hariraam Aathreya 2004-04-21 01:04:13 EDT
Answers to questions at:
 https://listman.redhat.com/archives/rhl-devel-list/2003-August/msg00154.html

Question:
* What set of fonts should be included, each font really should
   be justified as serving a different purpose.

Answer:
   Three fonts need to be included. Two as listed
   in the original report and a Tamil console font from :
http://zha.sourceforge.net/tmp/consoleTamilUni.bdf
(author: N. Sivaraj, sivaraj AT tamil DOT net )

  Justification for inclusion of Fonts:
  1. VagaiUni : 
     Tamil font which meets the Unicode standard
  2. TSCu_Paranar : 
     This font includes both Unicode & TSCII character encoding
     (TSCII is a legacy standard before Unicode was used)
     This font is useful since the Tamil computing community
     is still in the process of transitioning from TSCII to Unicode.
     Using this font one could read both TSCII & Unicode encoded
     data.
  3. consoleTamilUni.bdf : 
     A Tamil Console font.
----------------------
Question:
 * For each font, a summary of:
   - What is the license of the fonts?
   - Who drew the glyphs? If the font contains Roman characters
     as well, where did they come from?
   - Where did the design of the glyphs come from? (In some countries,
     font designs are patentable or otherwise protected, so a 
     exact copy of an existing commerical font is not a good idea.)
   - Where did the name come from? (Font names are trademarkable)

Answer:
1. VaigaiUni :
   - GPL license
   - Glyphs drawn by the author. Roman chars too drawn by author
   - Glyph design too by author
   - Named by the author based on a river name  concatenated
     with 'Uni' (to signify Unicode encoding)

2. TSCu_Paranar
   - GPL license
   - Glyphs drawn by the author. Roman chars too drawn by author
   - Glyph design too by author
   - Named by the author signifying a TSCII+Unicode encoding (TSCu)
     and name of Tamil saint (Paranar)

3. consoleTamilUni
   - GPL license
   - Glyphs drawn by the author. Roman chars too drawn by author
   - Glyph design too by author
   - Named by the author to signify that its a Unicode based console
     font for Tamil.

Question:
  * Some indication of how useful the bugs are with the software
   we ship currently.

Answer:
Question unclear to me.
Till date Tamil has not been 
shipped with RedHat/Fedora.
Comment 5 Bill Nottingham 2005-03-02 15:57:02 EST
This was done for FC-3.

Note You need to log in before you can comment on or make changes to this bug.