Bug 117880 - Rythmbox forgets libary contents between restarts
Rythmbox forgets libary contents between restarts
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 11:27 EST by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.6.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-25 10:19:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2004-03-09 11:27:14 EST
Description of problem:
When I close Rythmbox, and then opens it again, the media libary is 
empty. I have to re-add the contents of the libary each time.

Version-Release number of selected component (if applicable):
0.67

How reproducible:
Always (on this particular machine, my other machine is all right)

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Libary empty

Expected results:
Remembering the contents of the libary

Additional info:
Comment 1 Kyrre Ness Sjøbæk 2004-03-09 12:48:25 EST
Hmm... When i tried to open Rythmbox, I got the message asking me
about where I stored my music. I ansvered, and it found my songs. But
when I restarted, the libary was empty. I have tried to delete the
rythmbox folders under ~/.gconf/apps and ~/.gnome2 in hope that this
would reset the config. I did not do this before getting asked about
which folder I used. The folders are both regenerated.
Comment 2 John Thacker 2004-03-11 02:24:41 EST
Known bug with 0.6.7-- it's only triggered if the user has never run
rhythmbox on that particular machine, apparently, which is why you're
seeing it on only one machine.

Fixed with the new upstream release of 0.6.8, released 05 March 2004
and should hopefully make it in before FC2
Comment 3 Kyrre Ness Sjøbæk 2004-03-11 16:50:47 EST
what do you mean? I have ran rythmbox several times, both before
upgrading from the FC1 boxed version, and also after upgrading.

The problem is that each and every time I open rythmbox, I have to
reinsert my music folder...

Another thing I have seen is that it is somwhat poorly optimized - On
my 650 Mhz P3 384 MB RAM computer, rythmbox gives me about 20% CPU
utilisation when playing. XMMS stays at 4-10% while playing the same
oggs, using the eSound output plugin.

Why do I get the feeling that updating FC1 for such UI bugs are
getting lower and lower priority (such as this and the
fam+user-mountable-media-bug). FC2 is'nt out yet, and it should
therefore be patched until FC2 is out and stable.

just my 2 cent...
Comment 4 Colin Walters 2004-03-24 13:24:04 EST
Are you sure you're using 0.6.8?
Comment 5 Kyrre Ness Sjøbæk 2004-03-25 09:48:18 EST
please read again - I (was) using 1.6.7, and had a problem. It
dissapeared when upgrading to 1.6.8 from freshrpm's
Comment 6 Kyrre Ness Sjøbæk 2004-03-25 09:55:22 EST
Little off-topic, but still:

Thank you very much for providing me (and many others) with a great
music management application. It is really great (at least when pached
so it can play .mp3's as well... Don't the frauenhofer license allow
for mp3 to be distributed freely as long as you don't make money on
distributing it?) Anyway - ogg's have much better quality.

Even more off-topic:
When will it be possible to edit the song info directly using the
"properties" dialog? Isn't this quite simple to implement using the
id3* shell commands?

With regards
Kyrre Ness Sjøbæk
Comment 7 Colin Walters 2004-03-25 10:19:52 EST
We're working on tag editing, but it requires some more work in GStreamer.

Note You need to log in before you can comment on or make changes to this bug.