Bug 117882 - network configuration or internet wizard crashes
network configuration or internet wizard crashes
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2004-03-09 11:49 EST by cosmic nothing
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-03-11 06:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description cosmic nothing 2004-03-09 11:49:37 EST
Description of problem:
updated to enhanced errata (1.0.4-2.i386) to have wireless NIC option 
on network configuration tool, and now I can't set up ANYTHING 
related to the network!  When I start the network configuration tool, 
I get the error below.  The only reported bug I found similar to this 
said to update the network config to 1.0.4-2, which is what this is!  
PLEASE HELP!  It's taking forever just to try to get a wireless NIC 
working with Redhat 7.3!!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Go to main menu
2.System, Network Configuration -- error comes up as soon as network 
configuration tool starts up and then it won't let me do anything but 
close it
3. A similar error occurs when trying to run the Internet 
Configuration Wizard  

Actual results:
the error described above appears and won't let me continue with 
network config...

Expected results:
Network Configuration should run and allow me to add my wireless NIC!

Additional info:
Comment 1 cosmic nothing 2004-03-09 11:50:18 EST
here is the error:

Traceback (innermost last):
File "usr/sbin/neat", line 1441, in ?
  window - mainDialog()
File "usr/sbin/neat", line 237, in_init_
File "usr/sbin/neat", line 276, in load
File "usr/sbin/neat", line 285, in loadProfiles
  profilelist = getProfileList()
File "usr/sbin/../share/redhat-config-
network/netconfpkg/NCProfileList.py", line 91, in load
File "usr/sbin/../share/redhat-config-
network/netconfpkg/NCProfileList.py", line 965, in append
Attribute Error: setParent

Comment 2 Harald Hoyer 2004-03-10 03:34:08 EST
err... this sounds like an incomplete installation...
what does:
# rpm -q redhat-config-network
# rpm -V redhat-config-network

Comment 3 cosmic nothing 2004-03-10 09:32:20 EST
rpm -q redhat-config-network outputs the following:

rpm -V redhat-config-network outputs a TON of stuff, and since I have 
no easy way to get it from my linux laptop to this machine (no 
printer or network capabilities yet), I'm not going to type it all 
unless you really need it... it comes up with a bunch of flies 
under /usr/share/redhat-config-network/netconfpkg/; 
and /usr/share/redhat-config-network/pixmaps.

Comment 4 Harald Hoyer 2004-03-10 09:48:39 EST
seems like you have installed redhat-config-network several times...
try to use -U instead of -i for rpm...

# rpm -Uvh redhat-config-network-1.0.4-2.i386.rpm
Comment 5 Harald Hoyer 2004-03-10 09:49:29 EST
ok... you have to remove it first:
# rpm -e redhat-config-network
# rm -fr /usr/share/redhat-config-network*
# rpm -Uvh redhat-config-network-1.0.4-2.i386.rpm
Comment 6 Harald Hoyer 2004-03-10 09:52:16 EST
ok... use --allmatches to get rid of all installed
redhat-config-network versions

# rpm -e redhat-config-network --allmatches
# rm -fr /usr/share/redhat-config-network*
# rpm -Uvh redhat-config-network-1.0.4-2.i386.rpm

Comment 7 cosmic nothing 2004-03-10 13:15:51 EST
Ok...first, let me say thank you for your help...I am genuinely 
impressed at the speediness of your reply to this issue...it's so 
hard to find good help these days, and I sincerely appreciate it!  

So, I did all of this and it resolved this issue, but I'm a little 
confused and back to the original issue that started all of this.  I 
now have redhat-config-network-1.0.4-2 installed, and the network 
configuration screen comes up, but still does not give me 
the "Wireless NIC" option in the device type drop-down list of the 
Device window.  My wireless NIC DOES show up under the Hardware tab 
as "orinoco_cs" but it doesn't let me do anything with it and if I 
try to add an "ethernet" device (since I don't have the Wireless NIC 
option), it doesn't show the orinoco_cs as an option...what now??
Comment 8 Harald Hoyer 2004-03-11 06:56:40 EST
hmm, the version in RH 7.3 does not support Wireless NICs... sorry...
you have to configure it by hand... like this:
# cat >/etc/sysconfig/network-scripts/ifcfg-eth1 << EOF
Comment 9 cosmic nothing 2004-03-15 10:30:14 EST
I tried your script and it did not work.  Redhat recognizes my 
wireless NIC as eth0, so I modified your script to reflect that, and 
it does add a device of TYPE Wireless to the Network Hardware, but 
will not allow me to activate it (I click activate, and nothing 
happens).  If I go to the Network Device Configuration screen, it 
allows me to click activate there, but comes back saying "could not 
activate device eth0."   I looked at a few of the other net config 
scripts on there by default and they had an ipaddr="" and 
NETMASK= after BOOTPROTO=dhcp, so I tried adding those 
and it still did not work.  I know without a doubt that the wireless 
NIC works just fine because I can boot into Knoppix (from CD) and it 
immediately recognizes the NIC and I can surf flawlessly.   PLEASE 

Note You need to log in before you can comment on or make changes to this bug.