This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117884 - Updating kernel get "test install of lilo failed"
Updating kernel get "test install of lilo failed"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
:
Depends On:
Blocks: up2date-rhel3-u2
  Show dependency treegraph
 
Reported: 2004-03-09 12:02 EST by reubendb
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 17:04:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of up2date (980 bytes, text/plain)
2004-03-09 12:05 EST, reubendb
no flags Details
Ouput of 'lilo -t -v' (1.05 KB, text/plain)
2004-03-09 12:07 EST, reubendb
no flags Details
lilo.conf (1.00 KB, text/plain)
2004-04-14 08:23 EDT, reubendb
no flags Details
Latest lilo.conf after running the failed up2date (1.27 KB, text/plain)
2004-05-04 06:55 EDT, reubendb
no flags Details

  None (edit)
Description reubendb 2004-03-09 12:02:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:

Running up2date to install the latest kernel fix generates the
following error (note: I'm using LILO as boot loader) :
<snipped traceback statements>
...
Error installing lilo.conf  The message was:
test install of lilo failed

then up2date hung. I clicked "Cancel" on the up2date UI. Restarting
up2date seems to be okay, and gave the message that my system is fully
updated.

The new kernel is however sucessfully installed (2.4.21-9.0.1).

$> rpm -q kernel
<snip>
kernel-2.4.21-9.0.1.EL

$> rpm -q kernel-smp
<snip>
kernel-smp-2.4.21-9.0.1.EL

/etc/lilo.conf seems to be corret also:

image=/boot/vmlinuz-2.4.21-9.0.1.ELsmp
  label=2.4.21-9.0.1.E1
  initrd=/boot/initrd-2.4.21-9.0.1.ELsmp.img
  read-only
  append="root=LABEL=/"

Running /sbin/lilo manually seems to be OK too. I also tried with
'/sbin/lilo -t -v' to see the generated output and it seems fine
(attached). 

So I don't know why up2date failed



Version-Release number of selected component (if applicable):
up2date-4.2.5-1

How reproducible:
Didn't try

Steps to Reproduce:
1. Use LILO as boot loader & Wait for new kernel fixes in RHN
2. Run 'up2date'
3. Choose the new kernel for update
    

Actual Results:  Error as described above.

Expected Results:  up2date installed the new kernel, put it in
lilo.conf, re-install LILO, and quit gracefully after giving me the
summary of what packages were updated.

Additional info:
Comment 1 reubendb 2004-03-09 12:05:09 EST
Created attachment 98403 [details]
Output of up2date
Comment 2 reubendb 2004-03-09 12:07:07 EST
Created attachment 98404 [details]
Ouput of 'lilo -t -v'
Comment 3 Adrian Likins 2004-04-07 13:52:43 EDT
can I get a copy of the current working lilo.conf?

Trying to duplicate this and not having much
luck
Comment 4 reubendb 2004-04-14 08:23:18 EDT
Created attachment 99400 [details]
lilo.conf

Here my current lilo.conf. I tweaked this by hand to make the latest kernel
default when boot up. (sorry for late reply, been out much). Let me know if I
can help w/ anything else.
Comment 5 reubendb 2004-05-04 06:54:07 EDT
The latest kernel update failed again. Up2date hung after the
following message is displayed on the console. The rest of the
symptons are the same as the one I described above. The /etc/lilo.conf
content is the same as my previous attachment. The new lilo.conf after
running this (failed) up2date is attached. Running /sbin/lilo manually
works fine, although the new kernel is not put as the default in
lilo.conf by up2date. 


root]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 2069, in
doInstallation
    kernelsToInstall = up2date.installPackages(self.selectedPkgList,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 680, in
installPackages
    runPkgSpecialCases(pkgList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 729, in
runPkgSpecialCases
    apply(packageProvidesMethods[provideName],
[providesPackages[provideName]])
  File "/usr/share/rhn/up2date_client/up2date.py", line 825, in
installBootLoader
    __install_lilo(kernelList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 842, in
__install_lilo
    ret = lilocfg.installNewImages(kernelList,test=0)
  File "/usr/share/rhn/up2date_client/lilocfg.py", line 384, in
installNewImages
    raise LiloConfError("test install of lilo failed")
up2date_client.lilocfg.LiloConfError: Error installing lilo.conf  The
message was:
test install of lilo failed
Comment 6 reubendb 2004-05-04 06:55:18 EDT
Created attachment 99950 [details]
Latest lilo.conf after running the failed up2date
Comment 7 Ken Kleiner 2004-06-22 14:16:43 EDT
I am having the same problem.

When the up2date kernel install is running, should it be renaming current kernel area
to 'label=linux.bak', and new one to 'label=linux'?  

The kernel does install right, but a reboot won't boot it since the default boot is the
one with 'label=linux'.  

Or, is this the expected results?

Comment 8 Binand Sethumadhavan 2004-07-13 10:45:05 EDT
I am also having the same problem.

up2date installs the new kernel fine.

[root@morpheus root]# rpm -qa | grep kernel-2
kernel-2.4.21-4.EL
kernel-2.4.21-15.0.3.EL

But at the end of up2date, I get this message (there is no debug 
info):

Error installing lilo.conf  The message was:
test install of lilo failed

/etc/lilo.conf is also updated with the new kernel:

prompt
timeout=50
default=linux
boot=/dev/hda
map=/boot/map
install=/boot/boot.b
serial=0
linear

image=/boot/vmlinuz-2.4.21-15.0.3.EL
        label=2.4.21-15.0.3.E
        initrd=/boot/initrd-2.4.21-15.0.3.EL.img
        read-only
        append="console=ttyS0,115200 root=LABEL=/"
image=/boot/vmlinuz-2.4.21-4.EL
        label=linux
        initrd=/boot/initrd-2.4.21-4.EL.img
        read-only
        append="console=ttyS0,115200 root=LABEL=/"

The only piece missing is that the "default" entry is not changed, 
and lilo is not run. I have to do these steps manually on a number of 
servers.

My up2date is updating from a satellite server (not from RHN).
Comment 9 Adrian Likins 2004-08-25 17:04:20 EDT
I belive this should be fixed with the 2.1-U5 update and the
rhel3.0-U3 updates.
Comment 10 reubendb 2004-09-13 08:37:49 EDT
I installed latest up2date with RHEL 3 U3 updates. Then up2date
restarted and continued downloading the U3 updates. The same problem
happens at the end of the updates process when up2date tried to
install LILO. After killing the up2date, I had to manually changed
lilo.conf to use the latest kernel as default, then run /sbin/lilo,
which worked fine. So it looks like there's still a problem with
up2date and LILO.
Comment 11 Stephen Gillis 2004-09-22 14:06:28 EDT
I am having /have had the same problem for quite awhile. I will not talk about my 
experience with RH support on this, only that I am now looking for answers in other 
places. The problem is the same as others describe, run up2date, download and install 
kernel updates and Up2date appears to hang. Pressing cancel kills up2date, but appears 
to install the latest kernel. I have modified lilo.conf to run the latest kernel then run /sbin/
lilo which has worked fine in the past. 
Comment 12 Guillaume Gimenez 2004-10-04 10:48:47 EDT
The lilo configuration seems to be done twice : firstly by the rpm
itself and {secon,ba}dly by up2date.

Try to change the line
noBootLoader=0
to
noBootLoader=1
in /etc/sysconfig/rhn/up2date

The above kludge avoid up2date to configure lilo and will work until
the kernel rpms  stop  to handle lilo's configuration.

Note You need to log in before you can comment on or make changes to this bug.