Bug 1178848 - Failed to reset devices.list on /machine.slice: Invalid argument
Summary: Failed to reset devices.list on /machine.slice: Invalid argument
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Keywords: EasyFix, ZStream
Depends On: 1139223
Blocks: 1220298 1283498
TreeView+ depends on / blocked
 
Reported: 2015-01-05 14:41 UTC by Lukáš Nykrýn
Modified: 2015-12-30 05:59 UTC (History)
44 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Previously, the systemd service in some cases printed the following redundant error message in the journald log: Failed to reset devices.list on /machine.slice: Invalid argument With this update, the log_level value for these messages has been lowered, which prevents them from being logged.
Story Points: ---
Clone Of: 1139223
: 1220298 (view as bug list)
Environment:
Last Closed: 2015-11-19 15:02:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2092 normal SHIPPED_LIVE systemd bug fix and enhancement update 2015-11-19 12:13:57 UTC

Description Lukáš Nykrýn 2015-01-05 14:41:09 UTC
> Then I ran through my test cases.  I was able to get and set CPU shares for
> my VM without issue.  I checked my journal, and I saw the message mentioned
> above:
> 
>  Failed to reset devices.list on /machine.slice: Invalid argument

Yep we also need 
http://cgit.freedesktop.org/systemd/systemd/commit/?id=714e2e1d56b97dcf2ebae2d0447b48f21e38a600

But this is only a cosmetic issue. I don't think it deserves a respin for 7.1, especially in such late phase, but it should be mentioned in release notes though.

Comment 1 Peter Larsen 2015-01-19 22:38:26 UTC
Same issue seen on RHEL7

Comment 4 Robert Scheck 2015-03-11 11:40:43 UTC
Cross-filed case #01377172 on the Red Hat customer portal.

Comment 11 Lukáš Nykrýn 2015-05-11 08:48:53 UTC
Already fixed by rebase in 7.2

Comment 14 Robert Scheck 2015-07-29 09:37:42 UTC
The fix that was applied for RHBZ #1220298 unfortunately does not seem to
work, please cross-check if the non-working same fix is going to applied
for this RHBZ (for RHEL 7.2). I am also updating the case on the Red Hat
customer portal.

Comment 16 errata-xmlrpc 2015-11-19 15:02:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2092.html


Note You need to log in before you can comment on or make changes to this bug.