This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117898 - warning when booting system that has no floppydrive
warning when booting system that has no floppydrive
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhgb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-09 14:34 EST by Joerg Skottke
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 12:52:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joerg Skottke 2004-03-09 14:34:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
When booting into a system that does not have a floppy drive there is
an ugly message displayed, graphical boot is interrupted.

Version-Release number of selected component (if applicable):
all versions of test1

How reproducible:
Always

Steps to Reproduce:
1. switch off your floppy drive in BIOS and reboot
    

Actual Results:  Errormessage is displayed stating that it was
impossible to insert the kernel module for the floppy 

Expected Results:  Nothing (preferably) to sustain the graphical boot. 
eventually [failed]

Additional info:
Comment 1 Sahil Verma 2004-03-22 17:22:46 EST
Please change component to rhgb.
Comment 2 Joerg Skottke 2004-03-23 01:36:44 EST
Hi Sahil,

may i ask why to change the component?

The fact that rhgb is interrupted is a symptom but not the cause. I
think this is a matter of kernel configuration and as such the
component should be ok (?)
Comment 3 Sahil Verma 2004-03-23 13:24:50 EST
The kernel isn't calling insmod floppy, userspace is. If the hardware
device isn't found, an error is to be expected. So we need proper
device enumeration at boot and conditional module loading (I'm not
sure this can be done without HAL, DBUS et al) and rhgb should be able
to handle the error gracefully.
Comment 4 Joerg Skottke 2004-03-29 12:16:05 EST
changed component to rhgb as suggested by Sahil.
Comment 5 Daniel Veillard 2004-09-13 12:52:36 EDT
Booting my Dell laptop without the floppy connected, the system
fully boot graphically with rawhide now. There is an error
reported by modprobe for the floppy but it shows up on virtual
console 8, not on the vt1 or vte in graphical boot.
I tried it on a normal PC too after desactivating the floppy in the
BIOS and it completed the graphical boot normally.

  This seems fixed in Rawhide,

Daniel 

Note You need to log in before you can comment on or make changes to this bug.