Bug 117905 - Can not install Hylafax 4.1.8 on Fedora Core 1 AMD64
Summary: Can not install Hylafax 4.1.8 on Fedora Core 1 AMD64
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
(Show other bugs)
Version: 1
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-09 20:44 UTC by Boris Mironov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 04:07:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Boris Mironov 2004-03-09 20:44:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
It is not actually a problem of RPM.
I packed it up because there is no component like 'General component'.
But RPM plays own part in this issue.

When I'm trying to install hylafax-4.1.8 binary package for Fedora
Core 1 on my AMD64 it requires 'metamail' package. I loaded
metamail-2.7-28 from rpmfind.net

Now it is saying that it depends on libtermcap.so.2 and can not find
it. This file exists in /lib64, and I checked other places (eg., /lib,
/usr/lib, /usr/lib64). I also created symbolic links on
/lib64/libtermcap.so.2 where they did not exist.

Here is RPM's part:
rpm -q --whatprovides libtermcap.so.2
no package provides libtermcap.so.2



Version-Release number of selected component (if applicable):
4.2.1-0.30

How reproducible:
Always

Steps to Reproduce:
1. Load binary package
ftp://ftp.hylafax.org/binary/linux/redhat/RPMS/i386/hylafax-4.1.8-1rhp.i386.rpm

2. Load 'metamail-2.7-28.i386.rpm' from findrpm.net
3. Install hylafax package (it will ask to install 'metamail')
4. Try to install 'metamail' (it can not see 'libtermcap.so.2' that
exists in /lib64)
    

Actual Results:  Can not install fax server package

Expected Results:  ;) I should be able to install it

Additional info:

I've tried to use source code of Hylafax. But it can not be compiled
because of some problems between 32-bit program and 64-bit
architecture (I am not a C-programmer, sorry)

May be this is not an issue at all. Is there any 'metamail'-compatible
package in Fedora Core 1?

Comment 1 Bill Nottingham 2004-03-10 04:07:55 UTC
libtermcap is provided by the libtermcap package... you need the i386
version of that, which is in the i386 tree.

Comment 2 Boris Mironov 2004-03-10 14:23:59 UTC
Thanks a lot!

It works!


P.S. little enhancement request for rpm:
rpm -qa|grep libtermcap
now shows 2 rows. I assume one for i386 and other for x86_64. Could 
it be implemented as default setting for rpm to show architecture?

The statement:

rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE} %{ARCH}\n" | 
grep libtermcap

look bulky.


Thanks again,
Boris 


Note You need to log in before you can comment on or make changes to this bug.