Bug 1179060 - python-keystonemiddleware missing dependency for 2014.2.1 version
Summary: python-keystonemiddleware missing dependency for 2014.2.1 version
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: openstack-cinder
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: hguemar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-06 04:52 UTC by electrocucaracha
Modified: 2015-09-18 19:02 UTC (History)
4 users (show)

Fixed In Version: 2015.1.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-18 19:02:25 UTC


Attachments (Terms of Use)

Description electrocucaracha 2015-01-06 04:52:00 UTC
Description of problem:

After executing the instruction described on the OpenStack official documentation (http://docs.openstack.org/juno/install-guide/install/yum/content/cinder-install-controller-node.html), the cinder-api service fails to start.  According the logs, there is a missing python module(keystonemiddleware).

These are the requirements for Cinder v2014.2.1

https://github.com/openstack/cinder/blob/2014.2.1/requirements.txt

The Requires section of openstack-cinder spec should be match with :

http://pkgs.fedoraproject.org/cgit/openstack-cinder.git/tree/openstack-cinder.spec

Version-Release number of selected component (if applicable):

v2014.2.1

How reproducible:
Installing cinder packages and verify the status of  the services

Steps to Reproduce:
yum install -y yum-plugin-priorities
yum install -y http://repos.fedorapeople.org/repos/openstack/openstack-juno/rdo-release-juno-1.noarch.rpm
yum install -y http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum install -y openstack-utils
yum upgrade -y
yum clean all
yum update -y
yum install -y openstack-cinder python-cinderclient python-oslo-db

systemctl enable openstack-cinder-api.service openstack-cinder-scheduler.service
systemctl start openstack-cinder-api.service openstack-cinder-scheduler.service

systemctl status openstack-cinder-api.service

Actual results:

bash-4.2# systemctl status openstack-cinder-api
openstack-cinder-api.service - OpenStack Cinder API Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-cinder-api.service; enabled)
   Active: failed (Result: exit-code) since Tue 2015-01-06 04:10:16 UTC; 3min 32s ago
  Process: 20654 ExecStart=/usr/bin/cinder-api --config-file /usr/share/cinder/cinder-dist.conf --config-file /etc/cinder/cinder.conf --logfile /var/log/cinder/api.log (code=exited, status=1/FAILURE)
 Main PID: 20654 (code=exited, status=1/FAILURE)

Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/l...explicit
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder     value = import_string(found_expr)
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder   File "/usr/lib/python2.7/site-packages/paste/deploy/l...t_string
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder     return pkg_resources.EntryPoint.parse("x=" + s).load(False)
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder   File "/usr/lib/python2.7/site-packages/pkg_resources.... in load
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder     entry = __import__(self.module_name, globals(),glob...ame__'])
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder ImportError: No module named keystonemiddleware.auth_token
Jan 06 04:10:16 block-storage cinder-api[20654]: 2015-01-06 04:10:16.276 20654 TRACE cinder
Jan 06 04:10:16 block-storage systemd[1]: openstack-cinder-api.service: main process exited, code=exited, status=1/FAILURE
Jan 06 04:10:16 block-storage systemd[1]: Unit openstack-cinder-api.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

Expected results:

systemctl status openstack-cinder-api
openstack-cinder-api.service - OpenStack Cinder API Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-cinder-api.service; enabled)
   Active: active (running) since Tue 2015-01-06 04:15:40 UTC; 31s ago
 Main PID: 20727 (cinder-api)
   CGroup: /system.slice/openstack-cinder-api.service
           ├─20727 /usr/bin/python2 /usr/bin/cinder-api --config-file /usr/share/cinder/cinder-dist.conf --config-file /etc/cinder/cinder.conf --logfile /v...
           └─20734 /usr/bin/python2 /usr/bin/cinder-api --config-file /usr/share/cinder/cinder-dist.conf --config-file /etc/cinder/cinder.conf --logfile /v...

Jan 06 04:15:40 block-storage systemd[1]: Starting OpenStack Cinder API Server...
Jan 06 04:15:40 block-storage systemd[1]: Started OpenStack Cinder API Server.
Jan 06 04:15:40 block-storage cinder-api[20727]: 2015-01-06 04:15:40.695 20727 WARNING cinder.api [-] The v1 api is deprecated and will be removed ...nf file.
Hint: Some lines were ellipsized, use -l to show in full.

Additional info:

Comment 1 Eric Harney 2015-01-06 14:49:52 UTC
Juno packages for Cinder need to depend on python-keystonemiddleware.

Comment 2 Fedora Update System 2015-08-21 14:21:20 UTC
openstack-heat-2015.1.1-1.fc23 openstack-ceilometer-2015.1.1-1.fc23 openstack-neutron-2015.1.1-1.fc23 openstack-ironic-2015.1.1-1.fc23 openstack-sahara-2015.1.1-1.fc23 openstack-cinder-2015.1.1-1.fc23 openstack-glance-2015.1.1-1.fc23 openstack-nova-2015.1.1-1.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=1179060

Comment 3 Fedora Update System 2015-08-22 16:24:39 UTC
openstack-ceilometer-2015.1.1-1.fc23, openstack-cinder-2015.1.1-1.fc23, openstack-glance-2015.1.1-1.fc23, openstack-heat-2015.1.1-1.fc23, openstack-ironic-2015.1.1-1.fc23, openstack-neutron-2015.1.1-1.fc23, openstack-nova-2015.1.1-1.fc23, openstack-sahara-2015.1.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update openstack-nova openstack-glance openstack-cinder openstack-sahara openstack-ironic openstack-neutron openstack-ceilometer openstack-heat'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13914

Comment 4 Fedora Update System 2015-09-18 19:02:15 UTC
openstack-ceilometer-2015.1.1-1.fc23, openstack-cinder-2015.1.1-1.fc23, openstack-glance-2015.1.1-1.fc23, openstack-heat-2015.1.1-1.fc23, openstack-ironic-2015.1.1-1.fc23, openstack-neutron-2015.1.1-1.fc23, openstack-nova-2015.1.1-1.fc23, openstack-sahara-2015.1.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.