Bug 1179073 - python3-debug.i686 requires python3.i686 which is not multilib clean
Summary: python3-debug.i686 requires python3.i686 which is not multilib clean
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python3
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Orsava
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-06 07:01 UTC by Pavel Raiskup
Modified: 2017-04-28 14:35 UTC (History)
5 users (show)

Fixed In Version: python3-3.6.1-3.fc27 python3-3.6.1-4.fc26
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-28 14:35:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Pavel Raiskup 2015-01-06 07:01:30 UTC
SSIA.

Error: Transaction check error:
  file /usr/bin/python3.4m from install of python3-3.4.1-16.fc21.i686 conflicts with file from package python3-3.4.1-16.fc21.x86_64
  file /usr/bin/python3.4 from install of python3-3.4.1-16.fc21.i686 conflicts with file from package python3-3.4.1-16.fc21.x86_64
  file /usr/bin/python3.4dm conflicts between attempted installs of python3-debug-3.4.1-16.fc21.x86_64 and python3-debug-3.4.1-16.fc21.i686
  file /usr/bin/python3.4dm-config conflicts between attempted installs of python3-debug-3.4.1-16.fc21.x86_64 and python3-debug-3.4.1-16.fc21.i686

Comment 1 Fedora Admin XMLRPC Client 2015-05-12 12:02:19 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Fedora End Of Life 2015-11-04 12:02:29 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Pavel Raiskup 2015-11-04 12:05:37 UTC
$ sudo yum install python3-debug.i686
Last metadata expiration check performed 0:00:00 ago on Wed Nov  4 13:04:28 2015.
Dependencies resolved.
====================================================================================================================
 Package                          Arch                  Version                       Repository               Size
====================================================================================================================
Installing:
 python3                          i686                  3.4.3-5.fc23                  fedora                   53 k
 python3-debug                    i686                  3.4.3-5.fc23                  fedora                  2.2 M
 python3-devel                    i686                  3.4.3-5.fc23                  fedora                  188 k
 python3-libs                     i686                  3.4.3-5.fc23                  fedora                  6.6 M
 python3-test                     i686                  3.4.3-5.fc23                  fedora                  5.9 M
 python3-tkinter                  i686                  3.4.3-5.fc23                  fedora                  307 k
 python3-tools                    i686                  3.4.3-5.fc23                  fedora                  410 k

Transaction Summary
====================================================================================================================
Install  7 Packages

Total download size: 16 M
Installed size: 69 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): python3-3.4.3-5.fc23.i686.rpm                                                759 kB/s |  53 kB     00:00    
(2/7): python3-devel-3.4.3-5.fc23.i686.rpm                                          2.5 MB/s | 188 kB     00:00    
(3/7): python3-debug-3.4.3-5.fc23.i686.rpm                                           20 MB/s | 2.2 MB     00:00    
(4/7): python3-tkinter-3.4.3-5.fc23.i686.rpm                                        7.7 MB/s | 307 kB     00:00    
(5/7): python3-test-3.4.3-5.fc23.i686.rpm                                            16 MB/s | 5.9 MB     00:00    
(6/7): python3-libs-3.4.3-5.fc23.i686.rpm                                            17 MB/s | 6.6 MB     00:00    
(7/7): python3-tools-3.4.3-5.fc23.i686.rpm                                          1.3 MB/s | 410 kB     00:00    
--------------------------------------------------------------------------------------------------------------------
Total                                                                               8.8 MB/s |  16 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/bin/python3.4m from install of python3-3.4.3-5.fc23.i686 conflicts with file from package python3-3.4.3-5.fc23.x86_64
  file /usr/bin/python3.4 from install of python3-3.4.3-5.fc23.i686 conflicts with file from package python3-3.4.3-5.fc23.x86_64
  file /usr/bin/python3.4dm from install of python3-debug-3.4.3-5.fc23.i686 conflicts with file from package python3-debug-3.4.3-5.fc23.x86_64
  file /usr/bin/python3.4dm-config from install of python3-debug-3.4.3-5.fc23.i686 conflicts with file from package python3-debug-3.4.3-5.fc23.x86_64

Error Summary
-------------

Comment 4 Fedora Admin XMLRPC Client 2016-01-29 13:08:23 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 5 Fedora End Of Life 2016-11-24 11:21:39 UTC
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 6 Pavel Raiskup 2016-11-24 12:22:28 UTC
Still classified as multilib by pungi, but not installable as multilib.

Comment 7 Charalampos Stratakis 2017-04-12 15:01:51 UTC
Is this case still relevant?

Comment 8 Pavel Raiskup 2017-04-12 15:17:58 UTC
Yep:

$ sudo dnf install python3-debug.i686
....
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/bin/python3.5dm-config from install of python3-debug-3.5.3-4.fc25.i686 conflicts with file from package python3-debug-3.5.3-4.fc25.x86_64

Error Summary
-------------

Comment 9 Tomas Orsava 2017-04-12 15:46:54 UTC
(In reply to Pavel Raiskup from comment #6)
> Still classified as multilib by pungi, but not installable as multilib.

Python in Fedora is not capable of being paralely installed under multiple architectures. Would you know how to reclassify it in pungi? I don't have any experience with that tool.

Comment 10 Pavel Raiskup 2017-04-12 17:19:17 UTC
(In reply to Tomas Orsava from comment #9)
> (In reply to Pavel Raiskup from comment #6)
> > Still classified as multilib by pungi, but not installable as multilib.
> 
> Python in Fedora is not capable of being paralely installed under multiple
> architectures.

Other languages (e.g. perl or ruby) have parallel-installable *-libs, and thus
also *-devel.  Python has parallel installable *-libs only;  so how to build
against python-libs.i686 on x86_64 architecture then?  This seems like a bug
we should fix ...

> Would you know how to reclassify it in pungi? I don't have any
> experience with that tool.

Me neither, I'm actually not sure whether we should talk about `pungi` or
`mash`.  But it looks like blacklisting python*-devel packages is and option
at least for `mash`:
https://pagure.io/mash/blob/467b0cf4290efdd4cd356c2a6dc4d73c308ba7cc/f/mash/multilib.py#_230
https://pagure.io/mash/blob/467b0cf4290efdd4cd356c2a6dc4d73c308ba7cc/f/mash/multilib.py#_234

Comment 11 Tomas Orsava 2017-04-13 08:29:26 UTC
(In reply to Pavel Raiskup from comment #10)
> (In reply to Tomas Orsava from comment #9)
> > (In reply to Pavel Raiskup from comment #6)
> > > Still classified as multilib by pungi, but not installable as multilib.
> > 
> > Python in Fedora is not capable of being paralely installed under multiple
> > architectures.
> 
> Other languages (e.g. perl or ruby) have parallel-installable *-libs, and
> thus
> also *-devel.  Python has parallel installable *-libs only;  so how to build
> against python-libs.i686 on x86_64 architecture then?  This seems like a bug
> we should fix ...

Hm, I've checked it in rawhide and F24 and both python3-libs and python3-devel are paralely installable. The problem appears to be with python3-debug only. I'll look into it further.

Comment 12 Pavel Raiskup 2017-04-13 08:58:22 UTC
Ah, you are right - I confused python-devel with python-debug, sorry.  The
*-devel packages are fine for Python.

> The problem appears to be with python3-debug only. I'll look into it further.

Thanks!  Agreed;  python3-debug is the last item from python{,3}{,-debug}
quaternion.

Comment 13 Tomas Orsava 2017-04-13 14:38:19 UTC
I fixed the problem in python3-debug (file /usr/bin/python3.Xdm-config had different content on the two architectures, but not a arch specific filename/path), and I'm currently building it for rawhide and F26. It should be included in a F26 update soon.

Comment 14 Fedora Update System 2017-04-18 16:23:26 UTC
python3-docs-3.6.1-1.fc26 python3-3.6.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 15 Fedora Update System 2017-04-19 12:51:23 UTC
python3-3.6.1-3.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 16 Fedora Update System 2017-04-19 16:46:45 UTC
python3-3.6.1-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1918e9452a

Comment 17 Fedora Update System 2017-04-19 16:53:21 UTC
python3-3.6.1-4.fc26 python3-docs-3.6.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 18 Fedora Update System 2017-04-19 16:53:44 UTC
python3-3.6.1-4.fc26 python3-docs-3.6.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 19 Fedora Update System 2017-04-20 02:22:59 UTC
python3-3.6.1-4.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e1e5e717c6

Comment 20 Fedora Update System 2017-04-28 14:35:54 UTC
python3-3.6.1-4.fc26, python3-docs-3.6.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.