Bug 117929 - OpenOffice needs Japanese font alias to read MS Office docs.
OpenOffice needs Japanese font alias to read MS Office docs.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-10 01:28 EST by Nakai
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 13:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff for openoffice.spec (openoffice-1.1.0-24) (674 bytes, patch)
2004-03-10 01:32 EST, Nakai
no flags Details | Diff
a patch for the Japanese resourc file (2.35 KB, patch)
2004-03-10 01:33 EST, Nakai
no flags Details | Diff
Real Japanese Word doc (NDA issue removed) (333.50 KB, application/octet-stream)
2004-03-18 02:21 EST, Nakai
no flags Details
Convert realjpword.doc with Acrobat Reader 6.0 Standard(JP). (179.03 KB, application/octet-stream)
2004-03-18 02:24 EST, Nakai
no flags Details

  None (edit)
Description Nakai 2004-03-10 01:28:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
OpenOffice.org package doesn't have correct Japanese alias,
so user needs to set alias at his initial startup of OpenOffice.org.
That's very messy.

MS Mincho should be aliased to Kochi Mincho
MS Gothic should be aliased to Kochi Gothic
MS PMincho should be aliased to Kochi Mincho
MS PGothic should be aliased to Kochi Gothic


Version-Release number of selected component (if applicable):
openoffice.org-1.1.0-24

How reproducible:
Always

Steps to Reproduce:
1. mv ~/.rhopenoffice1.1/ to ~/.rhopenoffice1.1.orig (if you have it)
2. Run ooffice with a Japanese MS Office doc
3. There is not strings in the document.
4. Need to learn openoffice.org font aliases

Actual Results:  No font aliases

Expected Results:  Japanese Font alises by default

Additional info:

The attached patch does not break or affect other languages.

The crappy guys might think OpenOffice.org is already ready for Japanese
users because they need just add Japanese font aliases later, but it
doesn't make sense. All applications must have appropriate font
setting by themselves by default, without any additional user settings.
Otherwise, user needs to learn font settings for each application
before using it. That never happens on Microsoft Windows, they
understand it well.
Comment 1 Nakai 2004-03-10 01:32:20 EST
Created attachment 98419 [details]
Diff for openoffice.spec (openoffice-1.1.0-24)

Actually, the fix target is in the archive
./build/OOO_1_1_0/solver/645/unxlngi4.pro/pck/registry81.zip,
so the patch is applied at %install.
Comment 2 Nakai 2004-03-10 01:33:15 EST
Created attachment 98420 [details]
a patch for the Japanese resourc file
Comment 3 Dan Williams 2004-03-17 15:09:49 EST
Yukihiro, can you attach a document that has this problem, so that I
can develop a more permanent fix?  Thanks!
Comment 4 Nakai 2004-03-18 02:21:53 EST
Created attachment 98641 [details]
Real Japanese Word doc (NDA issue removed)
Comment 5 Nakai 2004-03-18 02:24:40 EST
Created attachment 98642 [details]
Convert realjpword.doc with Acrobat Reader 6.0 Standard(JP).

This pdf will show you how realjpword.doc looks like on Windows.
Comment 6 Nakai 2004-03-18 02:32:37 EST
Your 'Permanent Fix' means the upstream fix?

Kochi Mincho/Gothic should not be assumed to be system default
on any Linux distribution/OS.
Other distros uses other proprietary, beauty fonts.
Distro's domestic font aliases might make sense.
Comment 7 John Flanagan 2004-05-12 13:07:16 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-189.html

Note You need to log in before you can comment on or make changes to this bug.