Bug 117930 - iostat -x seeing a HUGE avgqu-sz number 100%, even when the system isn't doing anything.
iostat -x seeing a HUGE avgqu-sz number 100%, even when the system isn't d...
Status: CLOSED DUPLICATE of bug 98542
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysstat (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-10 01:47 EST by Franklin Abud
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Franklin Abud 2004-03-10 01:47:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
Customer are seeing a HUGE avgqu-sz number in  'iostat -x 5' and %util
of 100%, even when the system isn't doing anything. 
 
This seems to happen on every box that I've seen running RHEL. 
 
avg-cpu:  %user   %nice    %sys   %idle 
           0.00    0.00    0.00  100.00 
 
Device:    rrqm/s wrqm/s   r/s   w/s  rsec/s  wsec/s    rkB/s    wkB/s
avgrq-sz avgqu-sz    
await  svctm  %util 
 
/dev/hde     0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00
    0.00 8589804.59    0.00    
0.00 100.00 
/dev/hde1    0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00
    0.00     0.00    0.00   0.00    
0.00 
/dev/hde2    0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00
    0.00     0.00    0.00   0.00    
0.00 
/dev/hda     0.00   0.00  0.00  0.00    0.00    0.00     0.00     0.00
    0.00 42308.50    0.00    
0.00 100.00 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run the command iostat -x
2.
3.
    

Actual Results:  iostat -x is seeing a HUGE avgqu-sz number in 
'iostat -x 5' and %util of 100%, even when the system isn't doing
anything. 

Expected Results:  iostat should detect the right information

Additional info:
Comment 1 Charlie Bennett 2004-04-07 13:55:53 EDT

*** This bug has been marked as a duplicate of 98542 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.