Bug 117936 - update kernel from 2.4.22-1.2149.nptlsmp to 2.6.3-2.1.252smp and lvm-mod not loaded
Summary: update kernel from 2.4.22-1.2149.nptlsmp to 2.6.3-2.1.252smp and lvm-mod not ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm-obsolete (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Stephen Tweedie
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-10 08:58 UTC by Gilles Salvin
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 10:24:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gilles Salvin 2004-03-10 08:58:50 UTC
Description of problem:

system doesn't boot because lvm-mod not loaded .

Version-Release number of selected component (if applicable):


How reproducible:
fresh-install fedora with LVM partitions except /boot, 
then update kernel to 2.6

Steps to Reproduce:

1.fresh-install fedora with LVM partitions except /boot
2.update kernel to 2.6: 
rpm -Uvh modutils-2.4.25-10.i386.rpm
rpm -Uvh mkinitrd-3.5.15.1-2.i386.rpm lvm-1.0.3-17.i386.rpm \
lvm2-2.00.08-2.i386.rpm device-mapper-1.00.07-1.i386.rpm
rpm -ivh kernel-2.6.3-2.1.252.i686.rpm
rpm -ivh kernel-smp-2.6.3-2.1.252.i686.rpm
3. try to boot on new kernel 2.6.3-2.1.252smp
  
Actual results:
doesn't boot  :o(
lvm-mod not loaded /etc/lvmtab not found

Expected results:


Additional info:

Comment 1 Stephen Tweedie 2004-03-10 10:24:31 UTC
There's lots of ongoing work to get LVM-on-root working properly in
Fedora --- this should all be fixed properly in Rawhide now (or
shortly, once the last initscripts change gets committed: see bug
#117575.)


Note You need to log in before you can comment on or make changes to this bug.