Bug 1179420 - zipnote crashes, new version has fix
Summary: zipnote crashes, new version has fix
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: zip
Version: 21
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Petr Stodulka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-06 17:47 UTC by bryant
Modified: 2015-02-09 05:26 UTC (History)
4 users (show)

Fixed In Version: zip-3.0-10.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-01 00:23:18 UTC
Type: Bug


Attachments (Terms of Use)
Test zip file (128 bytes, application/zip)
2015-01-08 17:23 UTC, bryant
no flags Details

Description bryant 2015-01-06 17:47:41 UTC
Description of problem:
zipnote crashes when editing .zip files.


Version-Release number of selected component (if applicable):
zipenote 3.0 (July 5th 2008)


How reproducible:
Always


Steps to Reproduce:
1. Use `zipnote -w` to edit files within a zip archive

Actual results:
zipnote crashes with segfault

Expected results:
archive was edited


Additional info:
Other literature on the issue, including a patch to fix this bug:

http://www.linuxquestions.org/questions/linux-software-2/problems-with-zipnote-writing-to-files-4175502552/

and

http://www.linuxquestions.org/questions/slackware-14/request-slackware-info-zip-zipnote-be-patched-to-support-writing-back-comments-4175502665/

Comment 1 Petr Stodulka 2015-01-08 08:54:06 UTC
Hi, yes, this problem is here longer time (I know about it month ago) however when I test it, new version of zipnote doesn't remove this problem and crashes too. I will look at it soon, however it seems that this bug is here few years so I don't think that's really so urgent.

Comment 2 bryant 2015-01-08 17:22:44 UTC
A release that fixes this bug has already happened, if you read the two links I attached, version 3.1b (which is in Beta) has the fix.

I just downloaded, built, and tested 3.1c, and it worked fine in my test case, which I've attached. Considering this release is 4.5 years old, I'd imagine it's pretty stable. Don't know what the deal is with zipnotes release cycles. Additionally the 3.1 version provides support for zip files > 2GB, which is a nice feature.

To test this run the following, replacing zipnote with the executable you want to test:

printf "@ hello.txt\n@=goodbye.txt\n" | zipnote -w hello.zip

Comment 3 bryant 2015-01-08 17:23:17 UTC
Created attachment 977853 [details]
Test zip file

Comment 4 Petr Stodulka 2015-01-08 19:17:27 UTC
For you is probably stable, but for upstream not. I will add this as soon as it will be marked as stable by upstream - with zip and unzip too. If you want use it, you can install it on your machine yourself. In other way I will create patch when I finish more important things. If you create patch, I can check it and then add it to fedora earlier.

Comment 5 bryant 2015-01-09 17:39:01 UTC
Do you have any contact with the Info-ZIP devs? They don't want bugs opened to prompt them to make a release, but I'd like to contact the devs directly if possible, but I'm unsure of how to do that. There was even supposed to be a 31d beta release in November. Maybe if they knew that we're blocking on them having a non-beta release they might be more inclined to move forward with releasing one.

Comment 6 Petr Stodulka 2015-01-11 21:25:28 UTC
New beta was planned few months ago, however there are some bigger bugs (I don't know which are bigger for them now) and they didn't push new beta version on public. You can contact them only through their forum [0] after registration (and confirmation from their side if I remember well this process) with PM or topic.

There you can find info about plans and bugs. However they response sometimes with big delay - I wait for some responses even few months (if they response at all).

I think that the fastest way for new beta is creating of patches for bugs which are reported on forum and are not resolved yet. Unfortunately, it's not too much clear. If you create patch for some bug, you can look here too [1] for tests. If there is not test for your bug, you can write here some tests too. It saves time for testing of new patches. And this tests are used by upstream too. Test for this bug has number 41, however It's not written yet due to some unpredictable behaviour in some situations.

[0] http://www.info-zip.org/phpBB3/index.php
[1] https://github.com/pirat89/zip-tests.git

Comment 7 Petr Stodulka 2015-01-28 15:21:08 UTC
Oh, I see it now. I apologize for my blind eyes. I see the link to forum now. Yes, that's clear fix. I will send patched zipnote for tests. Thanks for patience.

Comment 8 Fedora Update System 2015-01-28 16:20:44 UTC
zip-3.0-10.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/zip-3.0-10.fc20

Comment 9 Fedora Update System 2015-01-28 16:20:51 UTC
zip-3.0-13.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/zip-3.0-13.fc21

Comment 10 Fedora Update System 2015-01-30 04:39:43 UTC
Package zip-3.0-13.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing zip-3.0-13.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1386/zip-3.0-13.fc21
then log in and leave karma (feedback).

Comment 11 bryant 2015-01-30 18:48:49 UTC
Done. Thanks for working on this pstodulk.

Comment 12 Fedora Update System 2015-02-01 00:23:18 UTC
zip-3.0-13.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-02-09 05:26:37 UTC
zip-3.0-10.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.