Bug 117949 - Weirdness with customising Portal/Portlet applications when running in XHTML
Summary: Weirdness with customising Portal/Portlet applications when running in XHTML
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: APLAWS (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Daniel Berrange
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-10 11:36 UTC by Jay Priest
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 14:25:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Priest 2004-03-10 11:36:34 UTC
Description of problem:
I changed the site output to XHTML and all is fine except when 
customising a portlet. The page only partially loads, and the bebop 
stylesheets [used by the portlet custom app] cause the rest of the 
page HTML to load in the customise text-area.

I havent an example, as camden wanted me to revert back to HTML 
output, but when you come to have a look at this, contact me and I'll 
temporarily change the workspace-index.xsl to XHML output to demo.

NB> This was in a 'theme' on the camden staging box

Version-Release number of selected component (if applicable):


How reproducible:
each time

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Daniel Berrange 2004-03-10 14:19:17 UTC
We recommend against outputting XHTML since it offers no concrete
benefits over HTML 4.0 and it has less widespread browser support.
Also, with free text entry fields (eg CMS body text) users will not
typically take care to enter XHTML, so the resulting complete pages
will not be wellformed even if the HTML from XSL template is.

If there are specific XSL changes you can provide, we can incorporate
them, but otherwise I'll close this as not a bug.


Comment 2 Jay Priest 2004-03-10 14:28:11 UTC
cheers Dan

thats cool - we had chosen HTML 4 for camden & generic templates - 
for the same reasons as you highlight, just that Arturo suggested I 
query 


Note You need to log in before you can comment on or make changes to this bug.