Bug 117958 - KDE incorrectly sets X resources, breaks "find" in Acrobat Reader
Summary: KDE incorrectly sets X resources, breaks "find" in Acrobat Reader
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-10 13:45 UTC by Dimitri Papadopoulos
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 20:31:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dimitri Papadopoulos 2004-03-10 13:45:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040113

Description of problem:
This file:
	$ cat /usr/share/apps/kdisplay/app-defaults/AcroRead.ad
	acroread*lprCommand: kprinter
	acroread*Foreground:               WINDOW_FOREGROUND
	acroread*Background:               WINDOW_BACKGROUND
	$ 
causes KDE to set X resources specific to Acrobat Reader:
	$ xrdb -query | fgrep acroread
	acroread*Background:    #ffffff
	acroread*Foreground:    #000000
	acroread*lprCommand:    kprinter
	$ 

However the resources are not correctly set, since there are many of
them ending up with Background or Foreground. From my Acrobat Reader
installation:
	$ cd /usr/local/acrobat-5.0.8/Reader/intellinux/app-defaults
	$ fgrep ground: AcroRead
	*Background:#999999999999
	*TabWindow.Background:#ffffffffffff
	*ToolTip.Background:#ffffffffcccc
	*TextHighlight.Background:#000000000000
	*AVTextEdit.background:white
	*AVTextEdit.foreground:black
	AcroRead.background:XtDefaultBackground
	AcroRead.XmScreen.background:XtDefaultBackground
	*AboutDlg*foreground:black
	*AboutDlg*background:white
	$ 
As you can see your "acroread*Background" setting overwrite all
Acrobat Reader resources ending with "Background". This is OK with
most of them, but it's not OK for "TextHighlight.Background" which
should obviously be different from "Background".

The result is that the "find" functionality of Acrobat Reader can't
work under KDE.

I suggest either explicitly setting:
	acroread*TextHighlight.Background: WINDOW_FOREGROUND
after:
	acroread*Background:               WINDOW_BACKGROUND
or replacing:
	acroread*Background:               WINDOW_BACKGROUND
with:
	acroread.Background:               WINDOW_BACKGROUND
or any other similar solution.


I'm trying to reproduce this bug on Fedora Core 2 beta but I'm stuck
with kernel bugs for now (no network, no CD drive, no USB) so I can't
test for now. I'll update this bug report when I'm able to boot Fedora
Core 2 without problems.


Version-Release number of selected component (if applicable):
kdebase-3.1-15

How reproducible:
Always

Comment 1 Dimitri Papadopoulos 2004-03-10 14:55:52 UTC
At first sight this seems to have been fixed in Fedora Core 2:
	$ cd /usr/share/apps/kdisplay/app-defaults
	$ cat AcroRead.ad
	acroread*lprCommand: kprinter
	Acroread.foreground:               WINDOW_FOREGROUND
	Acroread.background:               WINDOW_BACKGROUND
	AcroRead.borderColor:              WINDOW_FOREGROUND
	AcroRead.XmScreen.background:      WINDOW_BACKGROUND
	AcroRead.XmScreen.borderColor:     WINDOW_FOREGROUND
	
	$ 

I'll have to double-check as soon as I have updated my Fedora Core 2
machine to the latest packages and got it to boot properly.


Comment 2 Ngo Than 2004-04-05 20:31:32 UTC
it's fixed in current release


Note You need to log in before you can comment on or make changes to this bug.