Bug 117963 - yum fails to start. reporting: iterable argument required
yum fails to start. reporting: iterable argument required
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-10 09:51 EST by yuval aviel
Modified: 2014-01-21 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-20 10:51:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuval aviel 2004-03-10 09:51:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Background: I installed fresh FC2-t1. I tried to update with up2date
and it didn't work (it never worked for me "out of the box", starting
from RH8!). So I moved to 'yum update'. This also doesn't work.

I downloaded the latest package: yum-2.0.5-1.noarch.rpm, and still the
same error report (see below). What am I doing wrong?

yuval.



Version-Release number of selected component (if applicable):
yum-2.0.5-1.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.su
2.yum update
3.
    

Actual Results:  

lcnpc18:root # yum update
Unable to find pid
Gathering header information file(s) from server(s)
Server: Red Hat Linux 1.90 - i386 - Base
Traceback (most recent call last):
  File "/usr/bin/yum", line 30, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum/yummain.py", line 222, in main
    clientStuff.get_package_info_from_servers(serverlist, HeaderInfo)
  File "/usr/share/yum/clientStuff.py", line 835, in
get_package_info_from_servers
    progress_obj=None)
  File "/usr/share/yum/clientStuff.py", line 1224, in grab
    bandwidth, conf.retries, retrycodes, checkfunc)
  File "/usr/share/yum/urlgrabber.py", line 237, in retrygrab
    progress_obj, throttle, bandwidth)
  File "/usr/share/yum/urlgrabber.py", line 315, in urlgrab
    fo = urllib2.urlopen(url)
  File "/usr/lib/python2.3/urllib2.py", line 129, in urlopen
    return _opener.open(url, data)
  File "/usr/lib/python2.3/urllib2.py", line 326, in open
    '_open', req)
  File "/usr/lib/python2.3/urllib2.py", line 306, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.3/urllib2.py", line 491, in <lambda>
    lambda r, proxy=url, type=type, meth=self.proxy_open: \
  File "/usr/lib/python2.3/urllib2.py", line 498, in proxy_open
    if '@' in host:
TypeError: iterable argument required
lcnpc18:root # 

Expected Results:  yum succesfully updated your system.
Comment 1 yuval aviel 2004-03-10 09:58:24 EST
Oops, sorry - my mistake.
I had a wrong $http_proxy set. That lead to the error reported above.
Comment 2 Seth Vidal 2004-03-10 10:18:00 EST
odd error nevertheless, I'll see if I can find a place to catch this
exception.

Thanks
Comment 3 Michael Stenner 2004-03-10 10:26:43 EST
Yuval,  can you tell me what you had your proxy set to and what it
SHOULD be set to?  I don't need a real working proxy, but just the
nature of the difference.

It's normal to throw an error of the proxy setting is broken, but this
is clearly not an informative error :)  We should probably include
some format checking or at least better reporting.  I'd like to add
this to the test suite.  Thanks for the feedback.
Comment 4 yuval aviel 2004-03-20 14:44:41 EST
Surely an informative error report would help.
The http_proxy was set to wwwproxy.huji.ac.il:8080, where is should
have been set to null (or simply undefined).

Hope this help.

Note You need to log in before you can comment on or make changes to this bug.