This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 117966 - Request for patch to LVM
Request for patch to LVM
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: lvm (Show other bugs)
3.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-10 11:16 EST by William C. Mount
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 23:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Add vpath support to lvm tools (1.35 KB, patch)
2004-04-01 11:50 EST, Tom "spot" Callaway
no flags Details | Diff
IBM SDD support: /dev/vpath and multiple path (2.78 KB, patch)
2005-01-27 08:46 EST, Pierre Wendling
no flags Details | Diff

  None (edit)
Description William C. Mount 2004-03-10 11:16:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; 
T312461)

Description of problem:
When a box is attached to IBM Shark Storage, to take advantage of the 
multipathing, we must install IBM's SDD driver.  this makes the 
multipath devices show up as a /dev/vpath device.  I can perform all 
disk related tools on that device, fdisk, mkfs, etc.  I can use them 
in a software raid array.  However, I cannot use them with LVM.  LVM 
complains that it is not a valid scsi device.

Version-Release number of selected component (if applicable):
lvm-1.0.3-15

How reproducible:
Always

Steps to Reproduce:
1.Install SDD on ES3 with a box connected to shark.
2.Configure the SDD vpath devices
3.attempt to run pvcreate -f /dev/vpath...
    

Additional info:
Comment 1 Tom "spot" Callaway 2004-04-01 11:50:31 EST
Created attachment 99047 [details]
Add vpath support to lvm tools

This patch should enable vpath support in the lvm tools.
Comment 2 Tom "spot" Callaway 2004-04-01 12:24:56 EST
Also, test packages are available here:

http://people.redhat.com/tcallawa/lvm/

Could you please test them and see if this enables the lvm tools to
operate on the vpath device?
Comment 3 William C. Mount 2004-04-01 16:39:35 EST
So far so good.  I was able to create a volume group and logical 
volumes without any problems whatsoever.  I've got a few other things 
to test, but I'll keep you in the loop.

Thanks for your help!
Comment 4 Pierre Wendling 2005-01-27 08:46:47 EST
Created attachment 110296 [details]
IBM SDD support: /dev/vpath and multiple path
Comment 5 Pierre Wendling 2005-01-27 08:49:43 EST
pvcreate is ok since 1.0.8-9

multiple path problem in all versions up to and including 1.0.8-9:

after reboot or vgscan, the underlying /dev/sdX is used instead of
/dev/vpath, thus loosing failover and load balancing

steps to reproduce:
- pvcreate /dev/vpatha
- vgcreate myvg /dev/vpatha
- vgdisplay -v myvg
so far, so good (you see /dev/vpatha as PV Name in the Physical Volumes
section)

Then
- vgchange -a n myvg
- vgscan
- vgchange -a y myvg
- vgdisplay -v myvg
you'll see /dev/sdX in the PV Name field in the Physical Volumes

I've got a patch that might be used as a starting point. It works for
us. I've attached is to this case as attachment #110296 [details]
Comment 6 Heinz Mauelshagen 2005-01-27 09:22:59 EST
Patch incorparated and extended to cover EMC Powerpath too.
Comment 7 Dennis Gregorovic 2005-05-19 23:25:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-182.html
Comment 8 John Taber 2005-06-13 13:52:05 EDT
I seem to still have a problem with pvcreate after patching...:

[root@pni-dvnbu04 dev]# rpm -qi lvm
Name        : lvm                          Relocations: (not relocatable)
Version     : 1.0.8                             Vendor: Red Hat, Inc.
Release     : 12.2                          Build Date: Fri 18 Feb 2005 
07:43:33 AM MST
Install Date: Mon 13 Jun 2005 10:00:08 AM MST      Build Host: 
porky.build.redhat.com
Group       : System Environment/Base       Source RPM: lvm-1.0.8-12.2.src.rpm
Size        : 1241387                          License: GPL
Signature   : DSA/SHA1, Wed 11 May 2005 05:46:08 PM MST, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.sistina.com/products_lvm.htm
Summary     : Linux Logical Volume Manager utilities.
Description :
LVM includes all of the support for handling read/write operations on
physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
multiple devices (MD), see mdadd(8) or even loop devices, see
losetup(8)), creating volume groups (kind of virtual disks) from one
or more physical volumes and creating one or more logical volumes
(kind of logical partitions) in volume groups.

[root@pni-dvnbu04 dev]# pvcreate /dev/emcpowera
pvcreate -- invalid physical volume "/dev/emcpowera"


Am I doing something wrong?

Note You need to log in before you can comment on or make changes to this bug.