Bug 1179686 - Missing dependencies in calibre package
Summary: Missing dependencies in calibre package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 21
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1180750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-07 10:44 UTC by stephan
Modified: 2015-02-16 00:34 UTC (History)
8 users (show)

Fixed In Version: calibre-2.15.0-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-17 05:46:39 UTC


Attachments (Terms of Use)

Description stephan 2015-01-07 10:44:57 UTC
calibre.x86_64 0:2.12.0-1.fc21 misses the following dependencies:  qt5-qtlocation , qt5-qtsensors.

Steps to reproduce: install calibre for example on a fresh F21 system.

The following errors appear:
ImportError: libQt5Positioning.so.5
ImportError: libQt5Sensors.so.5

Manual installation of the packages is a working work-around.

Comment 1 Fedora Update System 2015-01-07 14:43:16 UTC
calibre-2.15.0-2.fc21, python-qt5-5.4-5.fc21, sip-4.16.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/calibre-2.15.0-2.fc21,python-qt5-5.4-5.fc21,sip-4.16.5-1.fc21

Comment 2 Fedora Update System 2015-01-07 23:53:26 UTC
Package calibre-2.15.0-2.fc21, python-qt5-5.4-5.fc21, sip-4.16.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing calibre-2.15.0-2.fc21 python-qt5-5.4-5.fc21 sip-4.16.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-0347/calibre-2.15.0-2.fc21,python-qt5-5.4-5.fc21,sip-4.16.5-1.fc21
then log in and leave karma (feedback).

Comment 3 stephan 2015-01-08 05:59:05 UTC
The problem persists.

# sudo yum remove qt5-qtlocation.x86_64 qt5-qtsensors.x86_64
# su -c 'yum update --enablerepo=updates-testing calibre-2.15.0-2.fc21 python-qt5-5.4-5.fc21 sip-4.16.5-1.fc21'
# calibre

Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib64/calibre/calibre/gui_launch.py", line 47, in calibre
    main(args)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 489, in main
    gui_debug=gui_debug)
  File "/usr/lib64/calibre/calibre/gui2/main.py", line 335, in run_gui
    from calibre.gui2.ui import Main
  File "/usr/lib64/calibre/calibre/gui2/ui.py", line 40, in <module>
    from calibre.gui2.init import LibraryViewMixin, LayoutMixin
  File "/usr/lib64/calibre/calibre/gui2/init.py", line 17, in <module>
    from calibre.gui2.library.views import BooksView, DeviceBooksView
  File "/usr/lib64/calibre/calibre/gui2/library/views.py", line 17, in <module>
    from calibre.gui2.library.delegates import (RatingDelegate, PubDateDelegate,
  File "/usr/lib64/calibre/calibre/gui2/library/delegates.py", line 22, in <module>
    from calibre.gui2.dialogs.comments_dialog import CommentsDialog
  File "/usr/lib64/calibre/calibre/gui2/dialogs/comments_dialog.py", line 8, in <module>
    from calibre.gui2.dialogs.comments_dialog_ui import Ui_CommentsDialog
  File "/usr/lib64/calibre/calibre/gui2/dialogs/comments_dialog_ui.py", line 41, in <module>
    from calibre.gui2.comments_editor import Editor
  File "/usr/lib64/calibre/calibre/gui2/comments_editor.py", line 17, in <module>
    from PyQt5.QtWebKitWidgets import QWebView, QWebPage
ImportError: libQt5Sensors.so.5

===

# yum deplist --enablerepo=updates-testing calibre-2.15.0-2.fc21 | grep qt5 

The dependencies don't seem to be updated. This still fixes it:

# sudo yum remove calibre qt5-qtlocation.x86_64 qt5-qtsensors.x86_64

Comment 4 Zbigniew Jędrzejewski-Szmek 2015-01-08 14:57:26 UTC
calibre-2.15.0-2.fc21.x86_64 requires python-qt5 >= 5.4-5.fc21,
and python-qt5-5.4-5.fc21.x86_64 requires libQt5Sensors.so.5()(64bit) and libQt5Positioning.so.5()(64bit) which are provided by qt5-qtsensors-5.4.0-2.fc21.x86_64 and qt5-qtlocation-5.4.0-2.fc21.x86_64.

On my system, removing either of those packages results in calibre being uninstalled.

I cannot reproduce your error.

Comment 5 Zbigniew Jędrzejewski-Szmek 2015-01-09 21:48:07 UTC
*** Bug 1180750 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-01-17 05:46:39 UTC
calibre-2.15.0-2.fc21, python-qt5-5.4-5.fc21, sip-4.16.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Olga Maciaszek-Sharma 2015-02-15 22:05:08 UTC
I could install calibre via yum, and then I could launch it for the first time and the configuration window opened, but then it stopped working and the main window is never launched. Removing it and reinstalling again doesn't work either.

I have also tried installing it via the gui package installation tool. - this doesn' work at all - calibre is not being installed.

Comment 8 Zbigniew Jędrzejewski-Szmek 2015-02-16 00:34:32 UTC
(In reply to Olga Maciaszek-Sharma from comment #7)
Open a new bug report. In this, specify what calibre version, yum version you have. Try running calibre from a terminal window, and paste the output.


Note You need to log in before you can comment on or make changes to this bug.