Bug 1179752 - undocumented options in abrt-cli
Summary: undocumented options in abrt-cli
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matej Habrnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-07 13:32 UTC by Karel Volný
Modified: 2015-06-30 20:20 UTC (History)
7 users (show)

Fixed In Version: gnome-abrt-1.0.0-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-30 20:20:14 UTC


Attachments (Terms of Use)

Description Karel Volný 2015-01-07 13:32:17 UTC
Description of problem:
The documentation of abrt-cli is severely lacking.

Version-Release number of selected component (if applicable):
abrt-tui-2.3.0-3.fc21.x86_64

How reproducible:
always

Steps to Reproduce:
1. get help for various abrt-cli commands
2. compare to abrt-cli manpage

Actual results:
$ abrt-cli list --help
Usage: abrt-cli list [options] [DIR]...

    -v, --verbose               Be verbose
    -n, --not-reported          List only not-reported problems
    -d, --detailed              Show detailed report
    -s, --since NUM             List only the problems more recent than specified timestamp
    -u, --until NUM             List only the problems older than specified timestamp

$ abrt-cli remove --help
Usage: abrt-cli rm [options] DIR...

    -v, --verbose               Be verbose

$ abrt-cli report --help
Usage: abrt-cli report [options] DIR...

    -v, --verbose               Be verbose
    -d, --delete                Remove PROBLEM_DIR after reporting

$ abrt-cli info --help
Usage: abrt-cli info [options] DIR...

    -v, --verbose               Be verbose
    -d, --detailed              Show detailed report
    -s, --size NUM              Text larger than this will be shown abridged

$ abrt-cli status --help
Usage: abrt-cli status [DIR]...

    -v, --verbose               Be verbose
    -b, --bare                  Print only the problem count without any message
    -s, --since NUM             Print only the problems more recent than specified timestamp

$ abrt-cli process --help
Usage: Without --since argument, iterates over all detected problems.

    -v, --verbose               Be verbose
    -s, --since NUM             Selects only problems detected after timestamp


...
SYNOPSIS
       abrt-cli list [-vdf] [DIR]...

       abrt-cli remove [-v] DIR...

       abrt-cli report [-v] DIR...

       abrt-cli info [-vd] [-s SIZE] DIR...

       abrt-cli process [-v] DIR...

OPTIONS
       -v,--verbose
           Be more verbose. Can be given multiple times.

       -d,--detailed
           Show detailed report

       -n,--not-reported
           List only not-reported problems

       -s,--size SIZE: Text larger than SIZE bytes will be shown abridged
...

Expected results:
the options described in manpage match to those from commandline

the meanings of options are explained consistently - does "-s" stand for "--size" or "--since"?

"-f" for the "list" command is ommited as abrt-cli reports it as invalid


Additional info:

Comment 1 Karel Volný 2015-01-07 13:45:23 UTC
also "-d" for "--delete" and "--detailed" is confusing, but probably this is a new RFE material to rename the short option ...?

Comment 2 Matej Habrnal 2015-05-21 10:13:42 UTC
I've opened a pull request which fixes the issue: https://github.com/abrt/abrt/pull/973

Comment 3 Fedora Update System 2015-06-18 08:58:44 UTC
gnome-abrt-1.0.0-2.fc21,abrt-2.3.0-5.fc21,libreport-2.3.0-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/gnome-abrt-1.0.0-2.fc21,abrt-2.3.0-5.fc21,libreport-2.3.0-7.fc21

Comment 4 Fedora Update System 2015-06-21 00:32:49 UTC
Package gnome-abrt-1.0.0-2.fc21, abrt-2.3.0-6.fc21, libreport-2.3.0-8.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-1.0.0-2.fc21 abrt-2.3.0-6.fc21 libreport-2.3.0-8.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10193/gnome-abrt-1.0.0-2.fc21,abrt-2.3.0-6.fc21,libreport-2.3.0-8.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-06-23 09:08:19 UTC
Package gnome-abrt-1.0.0-3.fc21, abrt-2.3.0-7.fc21, libreport-2.3.0-8.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-1.0.0-3.fc21 abrt-2.3.0-7.fc21 libreport-2.3.0-8.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-10193/gnome-abrt-1.0.0-3.fc21,abrt-2.3.0-7.fc21,libreport-2.3.0-8.fc21
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2015-06-30 20:20:14 UTC
gnome-abrt-1.0.0-3.fc21, abrt-2.3.0-7.fc21, libreport-2.3.0-8.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.