Bug 1179807 - ose_installer fails with uninitialized constant FileUtils
Summary: ose_installer fails with uninitialized constant FileUtils
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.4.0
Assignee: Tina Fitzgerald
QA Contact: Milan Falešník
URL:
Whiteboard:
Depends On:
Blocks: 1179956 1179957
TreeView+ depends on / blocked
 
Reported: 2015-01-07 15:20 UTC by Josh Carter
Modified: 2015-06-16 12:47 UTC (History)
5 users (show)

Fixed In Version: 5.4.0.0.11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1179956 (view as bug list)
Environment:
Last Closed: 2015-06-16 12:47:07 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1100 normal SHIPPED_LIVE CFME 5.4.0 bug fixes, and enhancement update 2015-06-16 16:28:42 UTC

Description Josh Carter 2015-01-07 15:20:29 UTC
Description of problem:

ose_installer attempts to create the directory for the @oseTemplatePath but fails with the following error. 

[----] E, [2015-01-07T15:17:03.722298 #22775:3a707a8] ERROR -- : Q-task_id([service_template_provision_task_1000000000022]) <AEMethod ose_installer>   NameError: uninitialized constant FileUtils
[----] E, [2015-01-07T15:17:03.723109 #22775:3a707a8] ERROR -- : Q-task_id([service_template_provision_task_1000000000022]) <AEMethod ose_installer>
[----] E, [2015-01-07T15:17:03.731207 #22775:d5e8a0] ERROR -- : Q-task_id([service_template_provision_task_1000000000022]) Method STDERR: <code: FileUtils.mkdir_p(dirname)>:274:in `<main>': uninitialized constant FileUtils (NameError)
[----] I, [2015-01-07T15:17:03.731656 #22775:d5e8a0]  INFO -- : Q-task_id([service_template_provision_task_1000000000022]) <AEMethod [RedHat/Portfolio/OpenShift/Installer/Methods/ose_installer]> Ending


Fix is to add " requires 'fileutils' to the top of the method. 

Version-Release number of selected component (if applicable):
5.3.2.5.20141218144833_50406a5 

How reproducible:
very

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Milan Falešník 2015-06-02 09:33:58 UTC
Verified in 5.4.0.4 that the added fileutils makes it work again, I see messages in the log that are past the FileUtils usage. The /root/.openshift directory did not exist before so it had to be created using fileutils.

Comment 5 errata-xmlrpc 2015-06-16 12:47:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1100.html


Note You need to log in before you can comment on or make changes to this bug.