Bug 117984 - [bluetooth] kernel oopses in hci_vhci_chr_close
[bluetooth] kernel oopses in hci_vhci_chr_close
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-10 14:51 EST by ajs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.6.4-1.305
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 13:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ajs 2004-03-10 14:51:46 EST
Description of problem:
When I try and log out I get what looks like a kernel crash.

If I log out from the GNOME GUI then everything freezes and I can't
even ping from another machine.

If I do a 'telinit 3' from another console the what looks like a call
trace flys by for a couple of minuits before I give up and hit the power.

Everything works with kernel-2.6.3-1.106

Version-Release number of selected component (if applicable):
kernel-2.6.3-1.110
kernel-2.6.3-1.116
kernel-2.6.3-1.118
kernel-2.6.3-2.1.238
kernel-2.6.3-2.1.242
kernel-2.6.3-2.1.246
kernel-2.6.3-2.1.253

How reproducible:
always

Steps to Reproduce:
1. boot
2. log in through gdm
3. go to another console
4. log in as root
5. 'telinit 3'

Additional Information:
Video card:
  ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500] rev 0

Computer:
  Sony VAIO PCG-GRX570

Sorry that I can't provide more information.  I don't know how to
collect it.
Comment 1 Bill Nottingham 2004-03-11 01:30:53 EST
Does it still crash if you disable DRI?
Comment 2 ajs 2004-03-11 11:42:18 EST
Yes it does, but the traceback stops after a while:

=================================================================
do_exit+0xbc/0x739
do_divide_error+0x0/0xaa
do_page_fault+0x2f8/0x447
kobject_put+0x2/0x14
alloc_skb+0x32/0xc3
__kmalloc+0x142/0x189
__kfree_skb+0xe3/0xeb
do_page_fault+0x0/0x447
kobject_put+0x2/0x14
hci_vhci_chr_close+0x31/0x3d [hci_vhci]
__fput+0x39/0xcb
filp_close+0x59/0x5f
put_files_struct+0x54/0xa7
do_exit+0x3dd/0x739
sys_exit_group+0x0/0xd
get_signal_to_deliver+0x7ab/0x860
do_signal=0x4e/0xbb
sys_select=0x348/0x442
sys_select=0x348/0x442
do_notify_resume+0x27/0x37

Code: 8b 1a 8d 42 04 89 04 24 89 d8 e8 4a ba 02 00 85 c0 74 19 53
 <0> Kernel panic: Fatal exception in tinterrupt
In interrupt handler - not syncing
=================================================================
Comment 3 ajs 2004-03-11 11:46:57 EST
Also, to correct the original list of problem kernels, kernel-2.6.
3-1.110 does not cause the crash.
Comment 4 ajs 2004-03-15 10:48:50 EST
I've disabled bluetooth in modprobe.conf and reenabled DRI.  Now
things work OK with at least kernel-2.6.3-2.1.253.

Do you need more information?
Comment 5 ajs 2004-04-05 13:54:46 EDT
I no longer see this problem with kernel-2.6.4-1.305

Note You need to log in before you can comment on or make changes to this bug.