Bug 1179893 - [RFE] Bundle GWT symbol maps in GWT application's rpm package
Summary: [RFE] Bundle GWT symbol maps in GWT application's rpm package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Yaniv Kaul
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On: 1179862
Blocks: 1138809 1182000
TreeView+ depends on / blocked
 
Reported: 2015-01-07 18:19 UTC by Einav Cohen
Modified: 2016-03-09 20:53 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1179862
: 1182000 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:53:58 UTC
oVirt Team: Integration
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 36655 master MERGED packaging: add gwt symbols packages Never
oVirt gerrit 36702 None None None Never

Description Einav Cohen 2015-01-07 18:19:37 UTC
+++ This bug was initially created as a clone of Bug #1179862 +++

This RFE applies to both WebAdmin & UserPortal.

During GWT application compilation, symbol maps (mapping from Java identifier to obfuscated JavaScript identifier) are produced as *.symbolMap files, located in following directories:

  frontend/webadmin/modules/webadmin/target/generated-gwt/WEB-INF/deploy/webadmin/symbolMaps
  frontend/webadmin/modules/userportal-gwtp/target/generated-gwt/WEB-INF/deploy/userportal/symbolMaps

These symbol maps can be very helpful when facing client-side errors manifested as obfuscated JavaScript stacktraces. Even though these symbol maps are not 100% accurate (see [1] for details), they are still a very good starting place.

[1] https://code.google.com/p/google-web-toolkit/wiki/SourceMaps (see "Details" section describing symbol maps)

Without using symbol maps, one has to compile GWT application in "draft" mode [2] and reproduce the problem on this "draft" application. Replacing "normal" GWT application with its "draft" version can be, however, problematic (especially in case the customer is the only one able to reproduce the error).

[2] http://www.ovirt.org/DebugFrontend#GWT_Draft_Compile

Symbol maps can be considered as meta-data bundled in WebAdmin & UserPortal rpm package.

Comment 1 Sandro Bonazzola 2015-01-14 09:07:14 UTC
Any other patch needed or can we move this to modified and clone to ZStream?

Comment 2 Alon Bar-Lev 2015-01-14 09:11:06 UTC
(In reply to Sandro Bonazzola from comment #1)
> Any other patch needed or can we move this to modified and clone to ZStream?

not that I am aware of.

Comment 3 Alon Bar-Lev 2015-01-14 09:22:37 UTC
if this is downstream 3.5.1 it will take the commit from upstream anyway... I am unsure why this bug is required.

Comment 5 Einav Cohen 2015-01-14 12:37:04 UTC
(In reply to Alon Bar-Lev from comment #3)
> if this is downstream 3.5.1 it will take the commit from upstream anyway...
> I am unsure why this bug is required.

AFAIK: if we want it in 3.4.z, we must ensure that it is fixed in 3.5(.z) first, hence this bug is needed.

Comment 6 Pavol Brilla 2015-10-20 14:12:32 UTC
# rpm -qa  rhevm-*-debuginfo
rhevm-webadmin-portal-debuginfo-3.6.0.1-0.1.el6.noarch
rhevm-userportal-debuginfo-3.6.0.1-0.1.el6.noarch

# du -shx /usr/share/ovirt-engine/gwt-symbols/*
644M    /usr/share/ovirt-engine/gwt-symbols/userportal
1.3G    /usr/share/ovirt-engine/gwt-symbols/webadmin

Comment 11 errata-xmlrpc 2016-03-09 20:53:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.