This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 118017 - system-config-samba fails to open edit users dialog, delete user option effected
system-config-samba fails to open edit users dialog, delete user option effected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-samba (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Brent Fox
http://www.andrewfarris.com/fedora/st...
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-11 00:06 EST by Andrew Farris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 10:26:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew Farris 2004-03-11 00:06:46 EST
Description of problem:
While system-config-samba displays the "Samba Users" dialog, clicking 
the "Edit Users" results in the Traceback below without opening the 
expected dialog.
----------------
Traceback (most recent call last):
  File "/usr/share/system-config-samba/sambaUserWin.py", line 144, in 
onEditUserButtonClicked
    user_dict = self.samba_user_data.getUserDict()
  File "/usr/share/system-config-samba/sambaUserData.py", line 86, in 
getUserDict
    if tmp_line[0] != '#':
IndexError: string index out of range
----------------

The "Delete User" button displays this similar Traceback, but appears 
to correctly remove the user from the dialog listbox.
----------------
Traceback (most recent call last):
  File "/usr/share/system-config-samba/sambaUserWin.py", line 164, in 
onDeleteUserButtonClicked
    self.samba_user_data.deleteUser(name, line)
  File "/usr/share/system-config-samba/sambaUserData.py", line 178, 
in deleteUser
    user_dict = self.getUserDict()
  File "/usr/share/system-config-samba/sambaUserData.py", line 86, in 
getUserDict
    if tmp_line[0] != '#':
IndexError: string index out of range
----------------

Version-Release number of selected component (if applicable):
system-config-samba-1.2.5-1

Related:
python-2.3.3-2.1
pygtk2-2.0.0-5.1
libuser-0.51.7-7.1.1
htmlview-2.0.0-12
samba-3.0.2a-1.1
usermode-1.69-5

How reproducible:
always

Steps to Reproduce:
1. Run system-config-samba as root
2. Select menu "Preferences", option "Samba Users"
3. Select a local logon user
4. Click the "Edit User" button
  
Actual results:
Edit Users dialog fails to display, Traceback displayed

Expected results:
Edit Users dialog box displayed

Additional info:
Last rawhide update 03/10/04 14:29:14 PST
Samba users have been previously configured with both the command 
line tools and SWAT
Comment 1 Brent Fox 2004-03-11 10:26:47 EST
This bug was caused due to blank lines in the smbusers file which was
not expected.  Should be fixed in system-config-samba-1.2.6-1 in
Rawhide.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.