Bug 1180190 - odb package missing gcc-plugin
Summary: odb package missing gcc-plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: odb
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dave Johansen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-08 15:23 UTC by Steven Côté
Modified: 2015-02-05 03:22 UTC (History)
4 users (show)

Fixed In Version: odb-2.3.0-7.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of: 1114497
Environment:
Last Closed: 2015-01-20 21:01:28 UTC


Attachments (Terms of Use)

Description Steven Côté 2015-01-08 15:23:24 UTC
Same problem as before, but with odb-2.3.0-6.fc21.x86_64

+++ This bug was initially created as a clone of Bug #1114497 +++

Description of problem:
Since the update to gcc to version 4.8.3, the gcc plugin that is packaged in odb remains in the 4.8.2 plugin directory and odb cannot be run because it is looking in the 4.8.3 plugin directory.

Version-Release number of selected component (if applicable):
odb 2.3.0-1
gcc 4.8.3-1


How reproducible:
Run "yum update"
This pulls in the latest gcc which breaks odb.

--- Additional comment from Jakub Jelinek on 2014-07-02 02:34:58 EDT ---

Just rebuild.  I wasn't aware odb also ships a gcc plugin, otherwise I would have rebuilt it together with all the other packages.

--- Additional comment from Fedora Update System on 2014-07-04 23:11:50 EDT ---

odb-2.3.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/odb-2.3.0-3.fc20

--- Additional comment from Fedora Update System on 2014-07-05 10:57:22 EDT ---

odb-2.3.0-3.fc20 has been pushed to the Fedora 20 testing repository.

--- Additional comment from Fedora Update System on 2014-07-15 22:01:52 EDT ---

odb-2.3.0-3.fc20 has been pushed to the Fedora 20 stable repository.

Comment 1 Fedora Update System 2015-01-09 03:14:14 UTC
odb-2.3.0-7.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/odb-2.3.0-7.fc21

Comment 2 Fedora Update System 2015-01-09 11:54:40 UTC
odb-2.3.0-7.fc21 has been pushed to the Fedora 21 testing repository.

Comment 3 Steven Côté 2015-01-13 10:22:31 UTC
I've just tried odb-2.3.0-7.fc21.x86_64 and it all works fine for me now. Thanks!

This probably isn't the right place to start a conversation about this, but is there any way this process can be automated?

Comment 4 Fedora Update System 2015-01-20 21:01:28 UTC
odb-2.3.0-7.fc21 has been pushed to the Fedora 21 stable repository.

Comment 5 Dave Johansen 2015-02-05 03:22:31 UTC
In reference to comment 3, I don't know of an automated solution, but I added myself to the gcc watchlist so I can be more on top of things like this.


Note You need to log in before you can comment on or make changes to this bug.