Bug 118021 - aliasing bug which causes mkfontscale to SIGSEGV or SIGILL
aliasing bug which causes mkfontscale to SIGSEGV or SIGILL
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Carl Worth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 02:16 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 11:09:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-03-11 02:16:41 EST
Dan Burcaw tracked this down on PPC yesterday and we discussed the
problem in IRC.

There's some kind of weird aliasing bug occuring in freetype,
which causes mkfontscale to SIGILL on ppc64 and ppc, and SEGV on
s390.

Elliot reported the problem initially about 2 weeks ago in IRC as
an mkfontscale bug, but we never dug into it because we were
going to update to xorg-x11 anyway.  The problem occurs on xorg
now also, however if HasFreetype2 is set to NO in host.def then
the problem does not occur.  This is because the freetype
included with X gets built and used instead, and X is built with
-fno-strict-aliasing, which seems to bypass the problem.

Since I'm trying very hard to get xorg-x11 built ASAP, and
tree-ready, I didn't want to wait until tomorrow to bounce this
off you, so I decided to update freetype myself for now to
2.1.7-3 with -fno-strict-aliasing added, in hopes that this will
resolve the problem for us for now.

I'll give you an update on wether this fix works or not tomorrow,
and we can decide to keep it/revert it/fix it in some other way,
etc.
Comment 1 Dan Burcaw 2004-03-11 02:33:52 EST
I've reported this upstream with a tad bit more detail
on where I think the bug exists. See the post to
devel@freetype.org:
http://www.freetype.org/pipermail/devel/2004-March/010293.html
Comment 2 Mike A. Harris 2004-03-11 22:01:48 EST
Ok, the freetype 2.1.7-3 that I built in dist-fc2 with
-fno-strict-aliasing, has been confirmed to resolve this issue
now.  xorg-x11 builds cleanly.

This might also be a problem in Fedora Core 1, with freetype 2.1.4,
as a test X build I did in the fc1 -scratch collinst failed
in a similar way.  Not important likely, unless we do an FC1/ppc
release though, which seems unlikely at this point.
Comment 3 Owen Taylor 2004-03-12 09:43:38 EST
This bug shouldn't be closed until we investigate it and either
file a GCC bug or an upstream freetype bug. (Dan Burcaw mailed
freetype-devel about this but without a lot of detail (was the 
mail truncated?), and I doubt anybody will investigate.)
Comment 5 Clemens Koller 2005-04-11 06:59:17 EDT
Please see also the thread in freetype-devel.

[ft-devel] Bug on PowerPC: Illegal Intruction in FT_Get_Name_Index

I have had exactly the same problems as you mentioned above.
PPC32 platform (to be more precise: embedded Freescale mpc8540 processor,
gcc-3.4-20050401, binutils 2.15.96, glibc-2.3.4).

It's in a -works-for-me- status now.
I also doubt if anybody will investigate this behaviour more
closely. I am not a Font-Code-Writer at all, but let me know if I
can assist.
Comment 6 Mike A. Harris 2006-06-14 11:09:47 EDT
I'm cleaning out bugzilla of bugs that I've filed over the last 3 years
which are either fixed and/or I no longer wish to track.

Closing bug as CURRENTRELEASE, as freetype is built properly in all OS
releases to avoid this problem.

If anyone is interested in fixing freetype's aliasing bugs, feel free
to send patches to the freetype project, or to submit a bug to the
freetype bug tracker.  There does not appear to be any value to leaving
the bug perpetually open in bugzilla though, as indicated in comment #4.




Comment 7 Alexei Podtelezhnikov 2007-01-15 08:03:39 EST
no-strict-aliasing does not seem to be necessary any longer.

Note You need to log in before you can comment on or make changes to this bug.