Bug 118025 - findutils doesn't rebuild without applied SELinux patch
Summary: findutils doesn't rebuild without applied SELinux patch
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: findutils   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-11 08:05 UTC by Robert Scheck
Modified: 2007-04-18 17:04 UTC (History)
0 users

Fixed In Version: 4.1.7-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 11:34:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch, that findutils is rebuildable without applied SELinux patch (16.50 KB, patch)
2004-03-11 08:07 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2004-03-11 08:05:00 UTC
Description of problem:
A rebuild of findutils without activated SELinux simply dies:
Patch #4 (findutils-4.1.7-d_type.patch):
+ patch -p1 -b --suffix .d_type -s
2 out of 25 hunks FAILED -- saving rejects to file find/parser.c.rej
Error: Bad exit status from /var/tmp/rpm-tmp.23825 (%prep)

Version-Release number of selected component (if applicable):
findutils-4.1.7-23

How reproducible & Steps to Reproduce:
Rebuild findutils without activated SELinux

Actual results:
The problem is caused by the patch #4, which is only optimated for 
the use with the SELinux patch.

Expected results:
I did the following to make it work and I would be very happy, if you
could do the same or do something better:

--- findutils.spec      2004-03-11 09:00:37.000000000 +0100
+++ findutils.spec.rsc  2004-03-11 09:02:45.000000000 +0100
@@ -18,6 +18,7 @@
 Patch3: findutils-selinux.patch
 %endif
 Patch4: findutils-4.1.7-d_type.patch
+Patch5: findutils-4.1.7-d_type-nose.patch
 Prereq: /sbin/install-info
 Buildroot: %{_tmppath}/%{name}-%{version}-root
 BuildRequires: libtool
@@ -42,8 +43,10 @@
 %if %{WITH_SELINUX}
 SELinux
 %patch3 -p1 -b .selinux
-%endif
 %patch4 -p1 -b .d_type
+%else
+%patch5 -p1 -b .d_type
+%endif

 rm -f config.guess config.sub
 libtoolize --force

Additional info:
Patch #5 (findutils-4.1.7-d_type-nose.patch) is attached. Thank you.

Comment 1 Robert Scheck 2004-03-11 08:07:26 UTC
Created attachment 98451 [details]
Patch, that findutils is rebuildable without applied SELinux patch

Comment 2 Tim Waugh 2004-03-11 11:34:48 UTC
Fixed in 4.1.7-24.


Note You need to log in before you can comment on or make changes to this bug.