Bug 118038 - xrestop's man page not included in package
xrestop's man page not included in package
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xrestop (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 07:19 EST by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 19:41:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix man page source syntax (383 bytes, patch)
2004-03-11 07:21 EST, Moritz Barsnick
no flags Details | Diff

  None (edit)
Description Moritz Barsnick 2004-03-11 07:19:16 EST
Description of problem:
In the xrestop package, the man page is not included.

Version-Release number of selected component (if applicable):
0.2-1

How reproducible:
always

Steps to Reproduce:
1. rpm -q xrestop
2.
3.
  
Actual results:
/usr/bin/xrestop

Expected results:
/usr/bin/xrestop
/usr/share/man/man1/xrestop.1.gz

Additional info:
Perhaps it was not included because it looks buggy, as if a sentence 
was missing. Actually, its roff syntax is somehow wrong. I'm 
attaching an easy fix. You still have to adapt the spec file as to 
not use "make SUBDIRS=" but rather "make", and add the %file.

(The package also won't build against an XFree86-devel which doesn't 
include libXRes.{so,a}, but I don't see a workaround for that.)
Comment 1 Moritz Barsnick 2004-03-11 07:21:17 EST
Created attachment 98455 [details]
Patch to fix man page source syntax

This patch fixes the roff syntax of xrestop's man page, so that the last line
(a shell code example) gets displayed.
Comment 2 Mike A. Harris 2004-04-15 19:41:24 EDT
Patch applied to 0.2-2 build in rawhide, and spec file updated
to include manpage, etc.

Note You need to log in before you can comment on or make changes to this bug.