Bug 118047 - 6-in-1 usb card reader doesn't show all the slots
Summary: 6-in-1 usb card reader doesn't show all the slots
Status: CLOSED DUPLICATE of bug 99377
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-11 14:06 UTC by Yusuf Goolamabbas
Modified: 2007-04-18 17:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yusuf Goolamabbas 2004-03-11 14:06:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b)
Gecko/20040311 Firefox/0.8.0+

Description of problem:
Hi, I have a 6-in-1 usb card reader. When I connect it to my rh9 box,
only the first slot shows up unless I put 

options scsi_mod max_scsi_luns=255 in
/etc/modules.conf

The output of /proc/scsi/scsi is

Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: Generic  Model: USB Storage-SMC  Rev: 0180
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 00 Lun: 00
  Vendor: LITE-ON  Model: LTR-48246S       Rev: SS0B
  Type:   CD-ROM                           ANSI SCSI revision: 02


Version-Release number of selected component (if applicable):
kernel-2.4.20-30.9

How reproducible:
Always

Steps to Reproduce:
1. attach 6-in-1 usb card reader to usb port
2. cat /proc/scsi/sci
3.
    

Actual Results:  only the first slot is seen as a scsi device

Expected Results:  all the slots should have been visible

Additional info:

Comment 1 Dave Jones 2004-05-26 12:35:59 UTC

*** This bug has been marked as a duplicate of 99377 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:01:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.