Bug 1180506 - pcs cluster stop behavior is not optimal and can lead to fencing nodes
Summary: pcs cluster stop behavior is not optimal and can lead to fencing nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
: 1165412 (view as bug list)
Depends On:
Blocks: 1184763 1186692
TreeView+ depends on / blocked
 
Reported: 2015-01-09 10:22 UTC by Fabio Massimo Di Nitto
Modified: 2015-03-05 09:20 UTC (History)
5 users (show)

Fixed In Version: pcs-0.9.137-12.el7
Doc Type: Bug Fix
Doc Text:
Cause: User tries to stop all cluster nodes using 'pcs cluster stop --all' Consequence: Resources are moved from node to node pointlessly as all nodes will eventually be stopped. Cluster looses quorum as soon as enough nodes has stopped. Fix: Stop nodes in parallel to prevent services being moved. Stop pacemaker on all the nodes, wait for it to finish, then stop corosync on the nodes to keep the cluster quorate as long as possible. Result: Services are not moved around the cluster. Quorum is lost at a time when pacemaker and all resources has been stopped.
Clone Of:
: 1184763 (view as bug list)
Environment:
Last Closed: 2015-03-05 09:20:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed fix for stop --all (7.13 KB, patch)
2015-01-15 14:47 UTC, Tomas Jelinek
no flags Details | Diff
proposed fix - loss of quorum warning (20.20 KB, patch)
2015-01-19 12:23 UTC, Tomas Jelinek
no flags Details | Diff
proposed fix for destroy --all (986 bytes, patch)
2015-01-20 15:40 UTC, Tomas Jelinek
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0415 normal SHIPPED_LIVE pcs bug fix and enhancement update 2015-03-05 14:16:41 UTC
Red Hat Bugzilla 1165412 None None None 2019-10-31 16:05:09 UTC
Red Hat Bugzilla 1184154 None None None 2019-10-31 16:05:09 UTC

Internal Links: 1165412 1184154

Description Fabio Massimo Di Nitto 2015-01-09 10:22:43 UTC
when issuing pcs cluster stop --all the stop sequence will:

stop all services on node1 -> stop cluster on node1
stop all services on node2 -> stop cluster on node2
....

There are 2 major problems with approach:

1) at somepoint there will be loss of quorum that can potentially block some resources that need quorum to stop (so when you get to the N node the resource will fail to stop and node will kill itself)

2) some applications (for example galera) have their own internal quorum and needs to be stopped all together to avoid corner case data corruption. Generally we can assume (for now at least) that external application quorum follows our quorum rules.

What we see in OpenStack is that stop --all on 3 node, will result in:

- moving tons of services around unnecessarily (since they will all die sooner or later)
- node fencing when stopping the last node because services can´t write to the db anymore (lack of internal quorum)

My recommendation here is:

on pcs cluster stop --all -> stop all resources -> stop cluster (at this point it´s irrelevant if it´s done one at a time or all together)

on pcs cluster stop -> this operation should verify if removing a node from the cluster will cause loss of quorum and abort. Of course we want to allow a manual override --pretty-please-i-know-i-will-lose-quorum-go-on

Comment 2 Tomas Jelinek 2015-01-15 14:47:00 UTC
Created attachment 980519 [details]
proposed fix for stop --all

related patch is already in upstream: https://github.com/feist/pcs/commit/7221995f47fa33eae271cce01d7b361d3578ef15

Comment 4 Tomas Jelinek 2015-01-19 12:23:04 UTC
Created attachment 981508 [details]
proposed fix - loss of quorum warning

Comment 5 Tomas Jelinek 2015-01-20 15:40:57 UTC
Created attachment 981896 [details]
proposed fix for destroy --all

Comment 6 John Ruemker 2015-01-21 16:08:47 UTC
*** Bug 1165412 has been marked as a duplicate of this bug. ***

Comment 15 errata-xmlrpc 2015-03-05 09:20:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0415.html


Note You need to log in before you can comment on or make changes to this bug.