Bug 118053 - Upgrade to FC2 test1 leaves usb mouse non functional
Upgrade to FC2 test1 leaves usb mouse non functional
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-03-11 10:16 EST by Maxwell Bottiger
Modified: 2013-02-05 23:46 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-12 14:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maxwell Bottiger 2004-03-11 10:16:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
I upgraded my laptop from FC1 to FC2 test 1 and the external mouse has
stopped working.  FC1 automaticly detected both the glidepoint PS/2
mouse build into the comptuer and the usb mouse and set them up to be
used simultaneously.  This was the most desireable behavior.

Right now the built in glide point works ok, but the usb mouse is dead
to the world.  There is no light on the mouse, and I've tried
switching to different usb ports.  I ran both "hotplug usb" and
"kudzu" but neither of them saw any new hardware.  (I have checked the
mouse on other computers, and the hardware is fine)

I'm not aware of there being a new XF86config file being installed.  I
there was one installed then there is no matching .rpmsave file
generated by the installer.

BTW, this was listed in the system logs:

request_module: failed /sbin/modprobe -- char-major-10-134. error = 256
request_module: failed /sbin/modprobe -- char-major-10-134. error = 256
request_module: failed /sbin/modprobe -- char-major-10-134. error = 256

I don't know if it's related.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Just boot the laptop into it's default configuration

Actual Results:  USB mouse light went out once linux began the boot
process.  Now it is not functioning

Expected Results:  I expected both the built in mouse and the external
mouse to work.

Additional info:
Comment 1 Mike A. Harris 2004-10-12 14:29:14 EDT
This upgrade issue is due to /dev/psaux no longer existing in
the 2.6.x kernel.  As such, the X server needs to be reconfigured
by running system-config-display --reconfig to generate a new
config file for use under the 2.6.x kernel.

I believe the final FC2 release munged the config file automatically
to do this.

Setting status to "CURRENTRELEASE"

Note You need to log in before you can comment on or make changes to this bug.