Bug 1180573 - Content dashboard has wrong links to [Invalid|Insufficient|Current] Subscriptions
Summary: Content dashboard has wrong links to [Invalid|Insufficient|Current] Subscript...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Dashboard
Version: 6.0.6
Hardware: All
OS: Linux
urgent
medium
Target Milestone: Unspecified
Assignee: Zach Huntington-Meath
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1379908 1394137 (view as bug list)
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1405524
TreeView+ depends on / blocked
 
Reported: 2015-01-09 13:44 UTC by Pavel Moravec
Modified: 2020-05-14 14:57 UTC (History)
11 users (show)

Fixed In Version: rubygem-katello-3.0.0.74-1,rubygem-katello-3.0.0.91-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1405524 (view as bug list)
Environment:
Last Closed: 2017-01-26 10:47:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
failed filter (66.13 KB, image/png)
2016-09-02 20:27 UTC, jcallaha
no flags Details
verification screenshot (207.43 KB, image/png)
2017-01-10 20:11 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15941 None None None 2016-08-02 15:04:53 UTC
Foreman Issue Tracker 17227 None None None 2016-12-07 22:06:58 UTC
Red Hat Knowledge Base (Solution) 1400223 None None None Never
Red Hat Product Errata RHBA-2017:0197 normal SHIPPED_LIVE Satellite 6.2.7 Async Bug Release 2017-01-26 15:38:38 UTC

Description Pavel Moravec 2015-01-09 13:44:22 UTC
Description of problem:
In katello dashboard, subscription widget provides links to lists of content hosts with [Invalid|Insufficient|Current] Subscriptions. Those links are wrong, as they apply on content host filters "status:red" instead of "status=red". Such filter is ignored on content host and the result shows _all_ content hosts.


Version-Release number of selected component (if applicable):
Sat 6.0.6


How reproducible:
100%


Steps to Reproduce:
1. In WebUI, open Content Dashboard (https://satellite.example.com/katello/dashboard#!=)
2. See "Invalid Subscriptions" is 0 in subscription widget.
3. Click to the "Invalid Subscriptions" link


Actual results:
URL https://satellite.example.com/content_hosts?search=status:red is loaded. I.e. content_hosts with applied filter "status:red".

All content hosts are displayed.


Expected results:
Proper URL is loaded under content_hosts, with applied filter "status=red".

No content host is displayed (assuming "Invalid Subscriptions" was really 0).


Additional info:
Can't be search=status%3Dred used? (%3D is encoding of '=') It works for me well as direct URL.

Comment 2 Tom McKay 2015-01-09 15:21:02 UTC
The search syntax for content hosts differs from hosts. For content hosts (and other katello objects) the syntax is elasticsearch, which uses ':' not '='.

This is correct:
status:red

Note that upstream katello is working towards correcting this but content hosts are not one of the resources yet converted.

Comment 3 Pavel Moravec 2015-01-09 17:25:56 UTC
(In reply to Tom McKay from comment #2)
> The search syntax for content hosts differs from hosts. For content hosts
> (and other katello objects) the syntax is elasticsearch, which uses ':' not
> '='.
> 
> This is correct:
> status:red
> 
> Note that upstream katello is working towards correcting this but content
> hosts are not one of the resources yet converted.

You mean that the dasboard is correct and general content_host search incorrect? Is there BZ to make content_host search in form property:value?

Comment 7 Zach Huntington-Meath 2016-08-02 14:15:24 UTC
Created redmine issue http://projects.theforeman.org/issues/15941 from this bug

Comment 8 Bryan Kearney 2016-08-16 14:05:44 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15941 has been closed

Comment 9 jcallaha 2016-09-02 20:26:58 UTC
Failed QA in Satellite 6.2.2.

The links appear to be correctly formatted, however after landing on the page, the "=valid|invalid|partial" is stripped and no proper filtering is done. See attached image.

url becomes 
https://<sat host>/content_hosts?search=subscription_status

Comment 10 jcallaha 2016-09-02 20:27:27 UTC
Created attachment 1197307 [details]
failed filter

Comment 13 Bryan Kearney 2016-11-11 14:27:34 UTC
*** Bug 1394137 has been marked as a duplicate of this bug. ***

Comment 14 Bryan Kearney 2016-11-11 14:28:34 UTC
*** Bug 1379908 has been marked as a duplicate of this bug. ***

Comment 16 jcallaha 2017-01-10 20:11:14 UTC
Created attachment 1239216 [details]
verification screenshot

Comment 18 errata-xmlrpc 2017-01-26 10:47:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0197


Note You need to log in before you can comment on or make changes to this bug.