Bug 1180733 - In Liferea, RSS feed contents are rendered in white on white and can't be seen: There is an upstream fix
Summary: In Liferea, RSS feed contents are rendered in white on white and can't be see...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liferea
Version: 21
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-09 20:26 UTC by Steven Rosenberg
Modified: 2015-02-02 17:21 UTC (History)
4 users (show)

Fixed In Version: liferea-1.10.13-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-02 17:21:22 UTC


Attachments (Terms of Use)
Here is a screen shot of what the RSS text window looks like in Liferea 1.10.11 in Fedora 21 with GNOME using the Adiwata Dark theme (119.51 KB, image/png)
2015-01-09 20:26 UTC, Steven Rosenberg
no flags Details

Description Steven Rosenberg 2015-01-09 20:26:24 UTC
Created attachment 978384 [details]
Here is a screen shot of what the RSS text window looks like in Liferea 1.10.11 in Fedora 21 with GNOME using the Adiwata Dark theme

Description of problem: When using the Adiwata Dark theme, RSS feed contents are not visible because the text is white on a white background.

Note: There is an upstream fix for this bug: https://github.com/lwindolf/liferea/issues/100


Version-Release number of selected component (if applicable): liferea-1.10.11-1.fc21


How reproducible: Run Liferea while using the Adiwata Dark theme in GNOME shell


Steps to Reproduce:
1. Use GNOME Tweak Tool to choose the Adiwata Dark theme
2. Run Liferea
3. Click on any individual feed item

Actual results:

RSS feed's text is white on white


Expected results:

RSS feed's text is readable (not white on white). Only hyperlinked text appears because it is rendered in blue on white.


Additional info: This has been fixes upstream in Liferea 1.10.12: https://github.com/lwindolf/liferea/issues/100

If this application is updated in Fedora, it should work with Adiwata Dark

Comment 1 Steven Rosenberg 2015-01-09 20:29:12 UTC
"has been fixed" upstream in Liferea 1.10.12 ... sorry for the typo.

Comment 2 Steven Rosenberg 2015-01-23 20:10:49 UTC
I grabbed the Liferea package from Fedora 22, liferea-1.10.12-1.fc22, installed it on my Fedora 21 system, and the problem is resolved.

So what F21 needs is for Liferea to be updated to 1.10.12.

Comment 3 Fedora Update System 2015-01-23 21:15:32 UTC
liferea-1.10.13-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/liferea-1.10.13-1.fc21

Comment 4 Fedora Update System 2015-01-26 02:29:42 UTC
Package liferea-1.10.13-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liferea-1.10.13-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-1083/liferea-1.10.13-1.fc21
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2015-02-02 17:21:22 UTC
liferea-1.10.13-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.