Bug 118074 - installer fails to enable network physical link
installer fails to enable network physical link
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 14:27 EST by Karen Spearel
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-18 11:48:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karen Spearel 2004-03-11 14:27:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031202

Description of problem:
The installer fails to turn on the link light and will not communicate
with the rest of the network during installation. Relevant F3 console
output is:

modules to insert sk98lin
loaded sk98lin from /modules/modules.cgz
inserted /tmp/sk98lin.ko
load module set done
....
need to set up networking
going to pick interface
only have one network device: eth
going to do getNetConfig
waiting for link...
0 seconds.
pump told us: SIOCSIFADDR: no such device

the above was using DHCP.  Deselecting DHCP and entering in the normal 
192.168.2.34 for this interface gives:

result of pumpSetupInterface is SIOCGIFFLAGS: No such device
reverse name lookup failed
starting to STEP_URL

On F4 I see:

sk98lin Network Device Driver v6.23
divert: allocating divert_blk for eth0
eth0: 3Com Gigabit LOM (3C940)
      PrefPort:A  RlmtMode:Check Link State
Mar 11 13:58:04 loader: failed to set default route: Network is
unreachable

At the point of failure, the link light on the hub is off.  Normally
exiting Linux on this system causes the link light to turn
off...deliberately crashing running system to leave the link up
doesn't help as the driver takes the link down as it is
loading...under normal circumstances, it would come up again shortly
after going down.

Version-Release number of selected component (if applicable):
Fedora Core 2 Test 1 for the x86_64

How reproducible:
Always

Steps to Reproduce:
1. make bootable installer CD 
2.run installer
3.get to point of asking to use DHCP or entering an IP #
4. can't go any further since there is no net connection
    

Actual Results:  Install cannot proceed for ntfs,ftp or http installs

Expected Results:  Installation to proceed

Additional info:
Comment 1 Karen Spearel 2004-03-11 14:33:08 EST
I forgot to mention that the original FC1 x86_64 version of the
installer did work with this hardware...the 3C940 was not
auto-detected...the sk98lin driver had to be selected from the list of
drivers but everything worked fine from that point on including using
DHCP to assign the IP address.
Comment 2 Jeremy Katz 2004-03-11 15:11:47 EST
This should be fixed once I rebuild anaconda with the kudzu that was
built yesterday.
Comment 3 Karen Spearel 2004-03-11 16:28:49 EST
excellent...my system is available as soon as something is ready for
testing.
Comment 4 Karen Spearel 2004-03-18 11:48:21 EST
boot.iso dated 3/17/2004 on my mirror fixes this issue completely
here.  Physical link comes up and gets an address from the dhcp server
on my router.  FTP install working fine.  As far as I am concerned,
this bug can be closed.  Thanks, guys ;)

Note You need to log in before you can comment on or make changes to this bug.