Bug 118080 - printf problem
Summary: printf problem
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gsl   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-11 20:06 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 15:49:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-03-11 20:06:08 UTC
Description of problem:

I just tried to compile Fedora Core2 Test1 package gsl-1.4-1

The compiler said

gsl-histogram.c(72): warning #267: the format string requires
additional arguments

The source code is

    gsl_histogram_fprintf (stdout, h, "%g", "%g");

%g expects a floating point number.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 David Binderman 2004-11-19 09:44:35 UTC
I can confirm that this bug still exists in Core 3,
some eight months later.

Comment 2 Ivana Varekova 2004-11-25 15:49:12 UTC
The function has correct arguments. 
It is not a bug.
Ivana Varekova

Comment 3 David Binderman 2004-12-21 13:56:08 UTC
>The function has correct arguments. 

I would be grateful if you could provide a little more information,
for example, where the compiler is getting it wrong.

Compilers producing wrong warning messages needs further investigation.



Note You need to log in before you can comment on or make changes to this bug.