Bug 1180815 - anaconda 22.14-1 back button does not work in "select disks" with USB mouse
Summary: anaconda 22.14-1 back button does not work in "select disks" with USB mouse
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: oxygen-gtk3
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F22AlphaFreezeException F22Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2015-01-10 16:22 UTC by satellitgo
Modified: 2015-04-17 15:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-17 15:02:26 UTC
Type: Bug


Attachments (Terms of Use)

Description satellitgo 2015-01-10 16:22:43 UTC
Description of problem:
anaconda 22.14-1 back button does not work in "select disks"
Have to use TAB to cycle to button and hit enter to proceed.
Bare metal install from DVD

Version-Release number of selected component (if applicable):
anaconda 22.14-1 KDE live 20150110 x86_64 from install icon on desktop
Bios Boot MSI Wind Box; USB Microsoft wheel mouse

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
f21 boxes and VirualBox installs do not seem to proceed with tabs

Comment 1 Fedora Blocker Bugs Application 2015-01-11 12:07:14 UTC
Proposed as a Freeze Exception for 22-alpha by Fedora user satellit using the blocker tracking app because:

 installer is almost unusable in KDE (gtk3 mismatch?)
KDE is release blocking

Comment 2 David Shea 2015-01-12 14:35:02 UTC
What exactly do you expect the back button to do? There is no concept of "back" in anaconda.

Comment 3 David Shea 2015-01-12 14:43:26 UTC
On second thought, I don't really care what you thought it would do. There is no back in anaconda, so of course a back mouse button that's barely supported in anything else isn't going to do anything.

Comment 4 satellitgo 2015-01-12 15:32:22 UTC
I am talking about the fact that the mouse click when over the back button (The button at the left top bar that returns you to the main hub) does not function in anaconda running under KDE
READ the BUG!

Comment 5 David Shea 2015-01-12 15:54:20 UTC
I think I can be excused from misreading a bug when you provide so few, and such fractured, details. There are no logs, you refer to a button label that doesn't exist, and you somehow that anaconda has somehow broken button behavior for KDE specifically. Every gtk program looks kind of messed up on the live image you mention. Maybe that's a hint.

Comment 6 Rex Dieter 2015-02-11 19:40:20 UTC
Turns out gtk3 in f22 has disabled the theming engine that oxygen-gtk3 uses, so the kde spin will no longer be able to use it.  We'll have to switch the default to something else (probably the default adwaita)

Comment 7 Petr Schindler 2015-03-02 21:34:07 UTC
Discussed at today's blocker review meeting [1].

This bug was accepted as Freeze Exception - This bug has been granted FE status. If a fix exists, please get it in before the next compose for testing.

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/

Comment 8 Jaroslav Reznik 2015-03-03 16:41:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 9 Fedora Admin XMLRPC Client 2015-04-17 14:58:01 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Rex Dieter 2015-04-17 15:02:26 UTC
oxygen-gtk3 is no longer used and has been retired.

f22 kde spin now uses (default) adwaita gtk theming


Note You need to log in before you can comment on or make changes to this bug.