Bug 1180838 - broken package dependencies
Summary: broken package dependencies
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: lirc
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-10 22:01 UTC by Wade Berrier
Modified: 2017-09-08 23:48 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-09-08 23:48:08 UTC


Attachments (Terms of Use)

Description Wade Berrier 2015-01-10 22:01:14 UTC
Description of problem:

installing lirc via yum results in a binary that can't be started because of missing libraries.

Version-Release number of selected component (if applicable): lirc-0.9.1a-4.el7


How reproducible:  Every time


Steps to Reproduce:
1.  yum install lirc
2.  /usr/sbin/lircd --nodaemon

Actual results:

/usr/sbin/lircd: error while loading shared libraries: IGUANAIR_0: cannot open shared object file: No such file or directory

Expected results:

It should load and be able to resolve all libraries.

Additional info:

ldd /usr/sbin/lircd shows:
        linux-vdso.so.1 =>  (0x00007fffbc3fe000)
        libasound.so.2 => /lib64/libasound.so.2 (0x00007f3162017000)
        IGUANAIR_0 => not found
        libirman.so.0 => /lib64/libirman.so.0 (0x00007f3161e10000)
        libportaudio.so.2 => /lib64/libportaudio.so.2 (0x00007f3161be1000)
        libm.so.6 => /lib64/libm.so.6 (0x00007f31618df000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007f31616db000)
        libusb-0.1.so.4 => /lib64/libusb-0.1.so.4 (0x00007f31614d5000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f31612b9000)
        libsystemd-daemon.so.0 => /lib64/libsystemd-daemon.so.0 (0x00007f31610b4000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f3160e9e000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f3160add000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f31608d8000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f31606d0000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f3162565000)
        libjack.so.0 => /lib64/libjack.so.0 (0x00007f3160477000)
        libusb-1.0.so.0 => /lib64/libusb-1.0.so.0 (0x00007f3160263000)
        libopus.so.0 => /lib64/libopus.so.0 (0x00007f3160021000)
        libstdc++.so.6 => /lib64/libstdc++.so.6 (0x00007f315fd1a000)

Something isn't quite right there with IGUANAIR_0.

Turns out there's a package that resolves this:

iguanaIR

Installing that package fixes it.  But, I imagine the package dependency wasn't created automatically because of the weird iguanaIR library packaging:

ldd /usr/sbin/lircd
        <snip>
        IGUANAIR_0 => /lib64/IGUANAIR_0 (0x00007f1d9de77000)
        <snip>

Comment 1 Richard Shaw 2015-02-11 21:46:10 UTC
Ok, I've worked on this off and on but I can't seem to make rpmbuild realize there's a dependency there. Something isn't working quite right.

Also, as of 0.9.2, the python dependency has changed to python3 which does not exist in epel7.

Comment 2 Alec Leamas 2015-07-30 15:59:16 UTC
fixed (finally!) in 2:1.1.0-9

Comment 3 Peter Bieringer 2017-07-30 10:35:17 UTC
I think this issue is still not fixed, because EPEL7 has still only lirc-0.9.1a-4.el7.x86_64 in repository, where is 1.1.0-9 for EL7?

Comment 4 Alec Leamas 2017-08-11 07:32:24 UTC
@richard: This is all my fault. The mess comes from (trying to) change the deps. "Old" lirc had iguanaIR as a dep, while the new is the other way around: iguanaIR depends on lirc. This reflects the change from a built-in iguanaIR driver to a plugin.

To make this change more interesting,in the same cycle upstream iguanaIR changed the soname without actually changing the sources (they changed from autotools to cmake, which generated a new soname from same source). This basically got me stuck in a bad dependency circle, the loophole was to add the evil soname patching to iguanaIR + an epoch. 

BTW: isn't python3 available in epel-7 these days?

Hope this helps...

Comment 5 Richard Shaw 2017-08-11 12:27:18 UTC
Yes, as python34 it seems. I haven't had much time lately between $DAYJOB and $HOMELIFE but I'll see if I can dig into this.

Comment 6 Fedora Update System 2017-08-14 19:32:30 UTC
lirc-0.10.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 7 Fedora Update System 2017-08-15 07:50:04 UTC
lirc-0.10.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 8 Fedora Update System 2017-08-16 03:18:24 UTC
lirc-0.10.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 9 Fedora Update System 2017-08-18 20:21:52 UTC
lirc-0.10.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 10 Fedora Update System 2017-08-24 00:34:23 UTC
lirc-0.10.0-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 11 Fedora Update System 2017-08-24 23:47:20 UTC
lirc-0.10.0-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b29bef7216

Comment 12 Fedora Update System 2017-09-08 23:48:08 UTC
lirc-0.10.0-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.