Bug 118089 - kernel alsa drivers do not include intel-8x0m
kernel alsa drivers do not include intel-8x0m
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-11 15:56 EST by Sergey V. Udaltsov
Modified: 2007-04-18 13:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 18:58:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergey V. Udaltsov 2004-03-11 15:56:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040116 Galeon/1.3.13

Description of problem:
There is one driver for intel ac97 controller: intel8x0m. It is
included into the alsa package 1.0.2+ - but it is not in the core
kernel yet. Could you pretty please include it as a patch to the
kernel. I am asking not only because of the sound card. This driver
allows to work SmartLink winmodems - WITHOUT installing proprietary
binary drivers (tainting kernel etc etc), just with user-space daemon
(slmodemd).

This winmodem is very often in Centrino-based laptops so I think many
people would be grateful to you.

The ideal solution would be to included slmodemd as well - but these
is binary-only object file linked, so I am not sure about the licensing.

Version-Release number of selected component (if applicable):
kernel-2.6.3-100

How reproducible:
Always

Steps to Reproduce:
Just check the kernel, sound/pci directory

Additional info:
Comment 1 Dave Jones 2004-03-11 18:58:16 EST
Push the ALSA guys to push it upstream instead.
If theres a reason its not there already, theres likely an equally
good reason for not including it in Fedora.
Comment 2 Sergey V. Udaltsov 2004-03-11 19:11:42 EST
There is no special reason here. AFAIK it just takes time to push new
driver (even working one) to the official kernel.
http://sourceforge.net/mailarchive/forum.php?thread_id=4003716&forum_id=1752

Note You need to log in before you can comment on or make changes to this bug.