Bug 118093 - text UI does not configure ethernet interfaces
Summary: text UI does not configure ethernet interfaces
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-11 21:28 UTC by Colin Walters
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 15:58:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Colin Walters 2004-03-11 21:28:37 UTC
Description of problem:

Hi, when I run system-config-network-tui, select Ethernet, unselect
"Use DHCP", add some static information, select OK, and then select
Exit, there has been no effect on the system as far as I can tell.

(This is for FC2 Test 1, upgraded to the latest rawhide)

Comment 1 Colin Walters 2004-03-11 21:29:27 UTC
Oh and I also have the same behavior in FC1, so this isn't a new bug.

Comment 2 John (J5) Palmieri 2004-04-12 19:01:00 UTC
I took a look at this bug and it does change the network
configuration.  It however does not bring the network device down and
back up again.  If you make a change with system-config-network-tui
and then subsequently reboot or bring your device down and back up it
will reflect the change.  I am not sure if this is how the tool is
supposed to work.  If not the fix would be to ifdown and ifup the
device being configured upon the user clicking ok.

Comment 3 Warren Togami 2004-04-17 11:07:33 UTC
Colin, I use the TUI configurator often and I must use ifdown/ifup
afterward in order to use the new network configuration.  Is this not
the case for you?

Comment 4 Colin Walters 2004-04-18 08:15:12 UTC
Perhaps this was fixed since then - last I tried it, the configuration
files weren't changed, and ifup/ifdown didn't help.  (I would try it
now, but testing on my laptop would kick me off the VPN)

Comment 5 Colin Walters 2004-04-20 15:58:09 UTC
Yep, I can confirm it works, thanks.


Note You need to log in before you can comment on or make changes to this bug.