Bug 118095 - (IDE SIL) Bad SATA Sil 3112 performance
Summary: (IDE SIL) Bad SATA Sil 3112 performance
Status: CLOSED DUPLICATE of bug 119478
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-11 21:37 UTC by Milan Kerslager
Modified: 2013-07-03 02:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Milan Kerslager 2004-03-11 21:37:52 UTC
I have Kouwell 2-port SATA Sil 3112 PCI card. This gives bad
performance on x86 and x86_64 kernel (latest 2.4.21-9.0.1 on some PC
and on dual Opteron) even I used hdparm to burst data transfers:

$ hdparm -d1 -u1 -c1 -X66 -k1 /dev/hde
$ hdparm -tT /dev/hde
/dev/hde:
 Timing buffer-cache reads:   700 MB in  2.00 seconds = 350.00 MB/sec
 Timing buffered disk reads:   78 MB in  3.04 seconds =  25.66 MB/sec

This is about half of expected performance even RH's Knowledgebase
claim support for ICH5 and Sil3112 chipsets. I was unable to go over
UltraDMA2 (it says "not supported").

I saw suggestion to apply latest SATA patches from Jeff Garzik on LKML
(http://lwn.net/Articles/73094/) to get full performance but I was
unable to identify what he means when going through LKML archive...

Comment 1 Jeff Garzik 2004-06-14 17:47:40 UTC
You should be using the sata_sil driver not siimage.

This should be fixed in RHEL3 U3, with an upcoming update.


Comment 2 Milan Kerslager 2004-09-01 22:19:39 UTC
There is no sata_sil module in the 2.4.21-15.0.4.EL kernel.

The other bad news is that SATA is recognized as hd[ab] during kernel
boot along with other IDE interfaces so there is IMHO no possibility
to load separate sata_sil module.

It seems that I have to wait for U3 few more days :-#

Comment 3 Karl Latiss 2004-09-02 06:06:22 UTC
The silraid module is in kernel-unsupported - perhaps that is what you
are after?

Comment 4 Milan Kerslager 2004-09-02 12:50:00 UTC
This is a different module. Module sata_sil is in 2.4.21-20.EL from U3
update.

Comment 5 Milan Kerslager 2004-09-02 19:10:25 UTC
I have no clue how to init SATA disc with sata_sil module instead of
siimage (siimage is builded into the kernel). Is there a way how to
avoid inicialization of ide[12] (I have IDE discs too) without
recompiling the kernel without siimage?

Comment 6 Milan Kerslager 2004-10-20 18:46:38 UTC
Is there a reason to have siimage compiled into the kernel even there
is  sata_sil in place?

Old legacy IDE module for SATA could be dropped IMHO.

Comment 7 Jeff Garzik 2004-10-20 18:49:23 UTC
I would love to :)

Unfortunately, dropping siimage means breaking existing setups...


Comment 8 Milan Kerslager 2004-10-20 19:10:47 UTC
I will try to use ide=reverse. But what about U4 & drop siimage for SATA?

Comment 9 Milan Kerslager 2004-10-20 20:35:22 UTC
Well, ide=reverse works. But even I used ide2=noprobe ide3=noprobe
hde=noprobe hdf=noprobe hdg=noprobe hdh=noprobe, siimage takes Sil3112
chipset for itself during kernel boot (before initrd) so I'm unable to
load sata_sil module then.

I tryed to use onboard VIA SATA VT6420 & sata_via but it hangs or does
not detect connected disc so I'm completly lost with original RHEL3
2.4.21-20.ELsmp for AMD64 (dual Opteron 242 on MSI mainboard).

I have an academic licence so this is the last defense line for me :-(
and I'm going to recompile the kernel with no siimage. Or do you have
another idea? Thank you...

Comment 10 Peter Bieringer 2005-02-06 19:02:33 UTC
I ran into the same problem here after buying two new boxes, now I'm into great trouble 
because I have not much time to set them up.

Why not adding a kernel switch to the siimage.c to disable use by specifying a special 
option on kernel boot like siimage_skip=y (or siimage_load=n).

Comment 11 Jeff Garzik 2005-02-18 07:26:15 UTC

*** This bug has been marked as a duplicate of 119478 ***

Comment 12 Red Hat Bugzilla 2006-02-21 19:01:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.